5

that is a a completion of my question Datamodel in biblatex, hashname and biber, but I opened a new question because the problem is more problematic.

If any roots want to merge, no problem.

I want to declare new entrytype and new field. I have two solutions: - use \DeclareSourceMap to map entry field (in bib) to another output field (for use with \printfield{} - use new datamap model, to allow to have new fields in my output file.

For some reasons, I prefered to use the second way. So I read biblatex handbook.

I made a manuscripts.dbx file, with this content

\DeclareDatamodelEntrytypes{manuscript}
\DeclareDatamodelFields{datation}
\DeclareDatamodelEntryfields{datation}

If I read correctly the handbook, it's enough to allow to have datation field in my .bbl file.

My .bib file has this content

@manuscript{P1470,
    Library={BNF},
    Address={Paris},
    Datation={\textsc{viii}\textsuperscript{e} s.}
}

And my main file has this content

\documentclass{article}
\usepackage{fontspec}
\usepackage[datamodel=manuscripts,bibstyle=verbose,citestyle=verbose]{biblatex}
\bibliography{titi.bib}
\begin{document}
\nocite{*}
s
\printbibliography
\end{document}

When I run xelatex -> no problem

When I run biber -> the bbl output file is empty.

If I comment \DeclareDatamodelEntryfields{datation} -> the bbl output file is not empty, but the field datation is not added to the bbl output file.

If I comment Datation={\textsc{viii}\textsuperscript{e} s.} -> -> the bbl output file is not empty, but the field datation is not added to the bbl output file.

I am on Os X, with Biber 1.8

I I run with latemk, latexmk said "Command for 'biber example' gave return code 6400"

  • same problem with .cfg file (indeed, the .bcf file is the same). – Maïeul Nov 25 '13 at 19:17
  • I have mode \DeclareDatamodelFields[type=field,datatype=literal]. It's working. I was persuaded to have done that. It seems I have forgotten. Thanks for your help – Maïeul Nov 25 '13 at 19:19
  • The handbook did'nt say it was mandatory... – Maïeul Nov 25 '13 at 19:21
  • We can remove the comments – Guido Nov 25 '13 at 19:28
  • I will fix this in the manual and re-upload 2.8a. – PLK Nov 25 '13 at 20:37
6

When you define a new field with \DeclareDatamodelField you have to specify the type and the datatype. In your case you need.

\DeclareDatamodelFields[type=field,datatype=literal]{datation}

The biblatex manual does not specify whether such options are required.

  • yes, thank. I was persuaded to try it. Indeed not. – Maïeul Nov 25 '13 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.