2

I work in a company that produces its product manual using Latex and have developed standard ways of generating a .pdf document from a .tex file. One or two of us have installed the CTAN build 2013 package over the CentOS default rpms. The rest of users are using the default CentOS LaTeX RPMS which are quite out of date as they're from the CTAN 2007 build.

I had come across a problem where documents were defaulting to US paper size format even though I was using the following \documentclass in the TeX file header:

\documentclass[DIV=12,paper=A4,twoside]{scrartcl}

I thought that the statement

paper=A4

ensured that the formatting of the document output was A4. This was not the case! I found that the page size was still shown as 'US Letter' in the document properties in the pdf viewer. On the machines that had CTAN build 2013 package installed (and where the directory path was correctly set to ensure that the 2013 CTAN build was used) it was relatively simple thing to change the default paper size for the LaTeX environment using the command

tlmgr paper a4

However this command is not available where the LaTeX has been installed from the CentOS RPMS. Apparently it's not possible to install this utility on its own.

Is there a command to specify the A4 page size as a global default when you don't have the tlmgr command available. One solution might be to use a command like

\usepackage[a4paper]{geometry}

In the .tex header file that would ensure that A4 paper size is always used however I need to be sure that it won't interfere (or override) with the Koma scrartcl document class?

I'd be very interested to get advice and thoughts from other users who've had this issue.

migrated from stackoverflow.com Nov 26 '13 at 4:14

This question came from our site for professional and enthusiast programmers.

  • One option could be to run pdflatex using the following command line: pdflatex \AtBeginDocument{\usepackage[a4paper]{geometry}} \input{<file>} where <file>.tex is the file you want to compile. – Werner Nov 26 '13 at 5:59
2

For the scrartcl class and others in this family, the default is not to set the paper size infomation in the output file, just to set the LaTeX lengths; under pdflatex the output file then gets the dimensions of the system default. This can be changed by adding the option pagesize to the documentclass. For example, choosing a non-standard size:

\documentclass[paper=b5,pagesize,DIV=12,twoside]{scrartcl}

\begin{document}
Test.
\end{document}

the viewer reports that the pdf is 17.6x25.0cm, whereas without pagesize on my system it is 21.0x29.7cm (I need to close my viewer between file changes to see a reported change of information).

If you want to move this pagesize setting out of the file, not sure that is a good thing, then you can create a typearea.cfg containing

\KOMAoptions{pagesize}

placed either in the current directory of the project, or in the local texmf tree (where will be picked up by all your scrartcl documents).

  • Doesn't the fact that "For the scrartcl class and others in this family, the default is not to set the paper size infomation in the output file, just to set the LaTeX lengths." only apply for postscript output? When using pdflatex, there should always be a page size set in the pdf and thus, using "pdflatex" for compilation should already do the trick. – DCTLib Nov 26 '13 at 14:02
  • @Ruedi No - the scr documentation explicitly states that these classes do not set the output page size by default even with a paper option. I.e. without the pagesize option, the default is pagesize=false and the output pdf is given the dimensions of the system default paper size. – Andrew Swann Nov 26 '13 at 14:46
  • @Ruedi I have updated the wording of my answer a little - I hope it makes it clearer. – Andrew Swann Nov 26 '13 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy