1

How should I insert the AMS classification in the bottom of the first page ?

Google doesn't seem to say anything.

EDIT: Here is the requested code:

\documentclass[12pt,numbers=withendperiod]{scrartcl} 

\newcommand\blfootnote[1]{%
  \begingroup
  \renewcommand\thefootnote{}\footnote{#1}%
  \addtocounter{footnote}{-1}%
  \endgroup
}

\begin{document}
\title{}
\author{}
\date{}
\maketitle

\section{Introduction}

\blfootnote{\textup{2000} \textit{Mathematics Subject Classification}: \textup{11D72}} 

\end{document}
  • Hum, are you sure you have posted all the code that is sufficient to reproduce your problem? I am wondering if you have some modified definition of \deffootnote and \deffootnotemark? KOMA controls the presentation of footnotes in two different places, one is via \thefootnotemark which the code I gave suppresses, the other is via the formatting options in \deffootnote. It is possible that somewhere in your workflow the footnote presentation is redefined so that the footnote definition is something like \thefootnotemark), which will cause you to see what you saw. – Willie Wong Nov 27 '13 at 13:10
  • not really relevant to the question, but you should be citing the (current) 2010 classification, not 2000. – barbara beeton Nov 27 '13 at 14:05
2

The \subjclass command is defined in the ams class files, that is, it is defined in amsart.cls and amsbook.cls etc. In other words, it is not something you load from a package.

It essentially just sets a footnote. So you can follow this answer here to get a footnote without a marker, and just put in as the footnote text

\textup{2000} \textit{Mathematics Subject Classification}: \textup{<insert MSC here>}

Example:

\documentclass{scrartcl}

\makeatletter
\def\blfootnote{\gdef\@thefnmark{}\@footnotetext}
\makeatother

\begin{document}
\blfootnote{\textup{2000} \textit{Mathematics Subject Classification}:
code}
\end{document}

Which outputs on the bottom of the page:

enter image description here


Edit: It seems that the OP uses a different option for the presentation of the footnotes: I generally just use superscripts, but it appears that the OP may prefer numbers followed by a parenthesis. Here's a version that would allow that:

\documentclass{scrartcl}
\usepackage{etoolbox}

\newcommand\blfootnote[1]{%
  \begingroup
  \renewcommand\thefootnote{}\footnote{#1}%
  \addtocounter{footnote}{-1}%
  \endgroup
}
\deffootnote{0em}{1.6em}{\expandafter\ifdefempty\expandafter{\thefootnotemark}{}{\thefootnotemark)\enskip}}


\begin{document}
\blfootnote{\textup{2000} \textit{Mathematics Subject Classification}:
code}
\footnote{Normal footnote}
\end{document}

In this version etoolbox is used to conditionally set the parenthesis mark depending on whether \thefootnotemark is empty or not (the \expandafters are just kludged-together hacks since \ifdefempty doesn't expand all the way down, and it appears that \thefootnotemark expands to a macro which expands to a macro which expands to the empty string, so without the \expandafter the test fails). The output looks like this:

enter image description here

To further customise and tune using the \deffootnote command, please see the KOMA script guide.

  • This doesn't work sufficiently well, by which I mean that although a number does not appear in the footnote, the parenthesis sign ")" appears in its place. Any other suggestions ? – manenir Nov 27 '13 at 12:25
  • What do you mean by "this doesn't work"? Does it not show up? Do you get an error? – Willie Wong Nov 27 '13 at 12:26
  • Sorry, I edited my previous answer. – manenir Nov 27 '13 at 12:27
  • What parenthesis sign? Please edit your original post with a MWE showing the problem. With just a vanilla scrartcl document and using the code from this answer I don't see any parenthesis signs. – Willie Wong Nov 27 '13 at 12:30
  • Thank you Willie, again the same problem appears with the code you give: Instead of "2000 Mathematics...code" at the end of the page, there appears ")2000 Mathematics...code" – manenir Nov 27 '13 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.