2

I'm using the memoir class and I have put the following lines of code in the preamble:

\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{3}

So far, everything's worked just fine. But for unknown reasons, LaTeX has suddenly stopped numbering subsections in both the table of contents and the text. Has anyone had the same or a similar problem before and might be able to help me out?

closed as unclear what you're asking by egreg, Mensch, user31729, jub0bs, cmhughes Nov 13 '14 at 16:31

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    Full minimal example please. There are other memoir macros that can alter this, for example \mainmatter and \backmatter. – daleif Nov 27 '13 at 14:03
  • Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – Adam Liter Nov 27 '13 at 14:20
  • \documentclass[a4paper, 12pt, oneside]{memoir} ... formatting paper, setting headers, rules, etc., color package, ... \setcounter{secnumdepth}{3} \setcounter{tocdepth}{3} ... paragraph options, line spacing, citations, ... \begin{document} ... \end{document} – user41800 Nov 27 '13 at 14:22
  • 2
    You should be able to edit your own question, so you can put the MWE inside the question, rather than putting it in a comment where fewer people will see it. Also, you may want to take a look at the link describing what an MWE is and how to go about producing one. Is the MWE that you suggested in the comments one that will actually reproduce the problem? Also, welcome to TeX.SX! :-) – Adam Liter Nov 27 '13 at 14:46