I am trying to compile "bibtex filename.aux" in latex. It does not compile and the errors are:

  1. Package natbib Error: Bibliography not compatible with author-year citations ...mand\NAT@force@numbers{}\NAT@force@numbers

  2. File ended while scanning use of \@@BOOKMARK \begin{document}

  3. File ended while scanning use of \@@BOOKMARK \begin{document}

The main problem is the first error. The command line with the problem in the filename.aux says: \providecommand\NAT@force@numbers{}\NAT@force@numbers (So apparently this is the line with a problem)

Here are the lines in the .tex file

\usepackage{natbib}

text... \citep{author2002}...etc

I have no idea how to make it run. PLEASE HELP!!!

migrated from stackoverflow.com Nov 28 '13 at 9:23

This question came from our site for professional and enthusiast programmers.

  • Can you prepare a minimal example MWE that lets us reproduce the problem? Right now there isn't enough information. FYI: biblatex is a modern alternative and could be of interest for you. – Johannes_B Nov 28 '13 at 9:33
  • Which bibliography style file are you using? Did you try loading natbib with the option authoryear? – Mico Nov 28 '13 at 9:47
  • In my case I was using TexStudio 2.9.4 and I resolved this same issue by looking carefully in Tools -> Bibliography, a log file about the bibliography compilation, and I resolved every issue it has warned me, like missing commas. – srodriguex Apr 25 '15 at 13:48

You haven't told us which bibliography style you use, but it would appear to be one that generates a numeric citation style by default.

If the bibliography style is not completely incompatible with authoryear-style citations (a big if, given the first error message you report...), you could try issuing the command

\setcitestyle{authoryear}

after loading natbib so that \citet and \citep can create citations in the desired authoryear style. After adding the command given above, be sure to wipe out the .aux file and rerun LaTeX, BibTeX, and LaTeX (twice more) .

If your bibliography style does turn out to be incompatible with authoryear-style citations, you either need to find another, compatible style file or create your own custom .bst style file from scratch. Fortunately, the latter method isn't as difficult as it might seem, thanks to the existence of the custom-bib package (which was created, incidentally, by the author of the natbib package).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.