3

I am using BibLaTex with APA style and Biber backend.

The example document of biblatex-apa states that multiple in-text references should be automatically ordered complying the APA 6 style independent from the order of input in the \cite command.

However, this is not working for me. The references in the document are ordered as put in in the cite command.

E.g. \textcite{AuthorC2001, AuthorA2001, AuthorB2001} will be printed in the PDF as

AuthorC (2001), AuthorA (2001), AuthorB (2001)

instead of

AuthorA (2001), AuthorB (2001), AuthorC (2001)

5

I took me hours to find the answer. However, I just stumbled across the following posting.

Just put the option

 sortcites=true

in the the preamble.

E.g.:

 \usepackage[style=apa, backend=biber, sortcites=true]{biblatex}

Now everything works as expected.

  • 1
    I too dug forever to find this posting: thank you! Note the posting linked does not discuss this option... – mfloren Sep 25 '17 at 19:00
  • The linked posting does indeed not discuss this option. However, the posting somehow helped me -- magically -- to find the answer to my original question ;). – phx Mar 16 '18 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.