0

The nomenclature is cutting off some entries. I have more entries than one page can hold so instead of printing to another page, it is truncating the nomenclature and only printing the first few entries that can fit on one page. Anyone have a solution?

I'm using the article class if that helps.

MWE:

\documentclass[11pt, oneside]{article}       
\usepackage{geometry}                       
\geometry{letterpaper}                           
\usepackage{amsmath}
\usepackage{graphicx}               
\usepackage{amssymb}
\usepackage{nomencl}                
\usepackage{graphicx}
\usepackage{color}
\begin{document}

\nomenclature{$D_h$}{Hydraulic Diameter [m]}
\nomenclature{$P$}{Wetted Perimeter [m]}
\nomenclature{$\eta_f$}{Individual Fin Efficiency}

% plus a lot more entries

\printnomenclature

\section{Executive Summary}
% main body of text. no issues here

\end{document}
0

You shoud skip the second \usepackage{graphicx} and you shoud add \makenomenclature in the preamble of your document (best right after \usepackage{nomencl}).

You have to compile the document with something like:

latexmk -pdf ; makeindex n.nlo -s nomencl.ist -o n.nls ; makeindex n.nlo -s nomencl.ist -o n.nls ; latexmk -pdf

Pls check http://www.ctan.org/tex-archive/macros/latex/contrib/nomencl

(from the manual Page 2 and 3 ...) The next step is to invoke MakeIndex. You should instruct MakeIndex to use ⟨filename⟩.nlo as your input file, use nomencl.ist as your style file1, and write output to the file ⟨filename⟩.nls. How to do this depends on your implementation of MakeIndex. For most UNIX implementations you should write something like makeindex ⟨filename⟩.nlo -s nomencl.ist -o ⟨filename⟩.nls

Now you have the file ⟨filename⟩.nls that contains your nomenclature list properly ordered. The last step is to invoke LATEX on your master file ⟨filename⟩.tex once more. It will input your .nls file and process it accordingly to the current options. That’s all!

  • Yes. Everything seems to work great now. thanks – user41915 Nov 29 '13 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.