8

For some reason when I reference something in my text, it also gives the type of object referenced (like Tabel 1, instead of just 1). I understand, that this is not standard latex behavior, but I do not explicitly load packages, that should alter this. I guess, one of the packages I use silently does this.

Here is my MWE:

\documentclass[12pt, english, parskip, a4paper]{scrartcl}

\usepackage[journal=angew]{chemstyle}   % loads chemscheme, graphicx

\begin{document}
    \begin{table}[h]
        \caption{Test}
        \begin{tabular}{c}
            Test \\ 
        \end{tabular}
        \label{tab:test}
    \end{table}

    Look at Table~\ref{tab:test}.
\end{document}

This will print

Look at Table Table 1.

How can I get rid of this? Thanks!

  • Try unloading chemstyle ... – karlkoeller Nov 30 '13 at 12:47
  • 2
    chemstyleloads varioref. You can turn it off by adding the option varioref=false: \usepackage[journal=angew,varioref=false]{chemstyle} – DG' Nov 30 '13 at 12:48
  • chemstyle also centers the content of the environment. – Johannes_B Nov 30 '13 at 12:50
  • @DG' This was actually the solution. If you turn this into an answer, I will select it. One question still arises. The documentation of chemstyle only states, that it is loaded, but not what it is used for. Any ideas? – basseur Nov 30 '13 at 13:27
  • 1
    In text I prefer " ... Table 1 ..." with an uppercase 'T', since that Table is a proper noun. – Ethan Bolker Nov 30 '13 at 14:39
9

The package chemstyle loads varioref by default. This can be turned off with the option varioref=false. The relevant line in your example would therefore read:

\usepackage[journal=angew,varioref=false]{chemstyle}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.