5

apa6 class seems to be incompatible with \footnote{}. For instance this document:

\documentclass{apa6}
\begin{document}
    \footnote{This is a footnote.}
\end{document}

produces this error:

LaTeX Error: ftnright package used in one-column mode

The author says:

The root of this problem is an incompatibility with the ftnright package and xltxtra when using apa6. Evidently apa and apa6 redefine a macro used by xltxtra (or one of its dependents) that is causing this conflict, but I have not been able to pinpoint it. Because APA style requires an author note (which goes under the left column on the first page), footnotes on the first page must be placed under the right column; hence, the use of ftnright is required for apa6.... If anyone else can identify the conflict, I'll be happy to correct the apa6 code.

Footnotes are discouraged in APA style apparently because they can be expensive for publishers to typeset; however they are technically allowed, and I would like to use them for a dissertation that will not be published in a journal.

Is there a footnote package I can use that is compatible with apa6?

4
  • Can you post a minimal document that shows the problem?
    – Alan Munn
    Dec 1 '13 at 3:34
  • added minimal example
    – Jeff
    Dec 2 '13 at 18:48
  • If you actually add the titling elements (author, title etc.) and issue the \maketitle command, your document compiles.
    – Alan Munn
    Dec 2 '13 at 19:06
  • Another question: is your thesis going to be formatted in journal mode? (I.e, two column, single spaced?)
    – Alan Munn
    Dec 2 '13 at 19:35
5

As far as I can tell, there is no incompatibility between the apa6 class and regular \footnote commands. The error you are getting in your minimal example is caused by the fact that in jou mode (the default mode for the class), a two column document is expected, and ftnright package is loaded. However, since the class doesn't load the article class (upon which it is based) with the twocolumn option, it issues \twocolumn command inside the \maketitle command when in jou mode. Since your minimal document doesn't execute \maketitle, the fntright package issues an error, since it can only be used in twocolumn mode.

So there are two possible solutions to your problem:

  1. Issue a proper \maketitle command
  2. If you are not using the \maketitle command, issue \twocolumn as the first line after \begin{document}.
\documentclass{apa6}
\usepackage{kantlipsum}
\title{A title}
\author{An Author}
\affiliation{A University}
\leftheader{Author}
\authornote{Thanks}
\shorttitle{}

\begin{document}
\maketitle
%\twocolumn % if not using `\maketitle`
\kant*[1]\footnote{This is a footnote.}

\kant
\end{document}

As a side note, the explanation given by the apa6 author (I assume this was by email to you, since there is nothing like this in the documentation) is most certainly wrong, with respect to this particular problem, since the xltxtra package is not used with pdfLaTeX. However, there definitely are issues with using xltxtra (actually the issue is with the realscripts package) with the class, since the placement of the footnote rule is incorrect when that package is loaded. If you're not using XeLaTeX, this should not be a problem, and even if you are, the xltxtra package is not really needed.

However, even this problem can be solved, simply by loading the xltxtra (or realscripts) package before the \documentclass command:

\RequirePackage{xltxtra} % or {realscripts}
\documentclass{apa6}

output of code

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.