0

I have texlive installed (via the repositories) on ubuntu 13.10. The version number it lists is 2013.20130722, so I figure this is texlive 2013?

I have a Biolinum font file with path /usr/share/fonts/opentype/linux-libertine/LinBiolinum_R.otf.

Trying to load

\usepackage[T1]{fontenc}
\usepackage{libertine}
\renewcommand{\familydefault}{\sfdefault}
\usepackage[greek=n,biolinum]{libgreek}
\usepackage{mathastext}

everything is typeset as expected, except that all Greek letters are replaced with a space.

Is this a problem with my texlive installation, with the font file, the libgreek package or something else?

Edit. The code is

\documentclass[12pt,a4paper]{article}
\usepackage[T1]{fontenc}
\usepackage{libertine}
\renewcommand{\familydefault}{\sfdefault}
\usepackage[greek=n,biolinum]{libgreek}
\usepackage{mathastext}
\begin{document}
  $\Gamma$
\end{document}

and libertine-legacy is installed (correctly, I hope).

3
  • Please, add code showing the issue.
    – egreg
    Dec 2, 2013 at 13:51
  • If libertine-legacy is installed, the console output or the log should show things like fonts/type1/public/libertine-legacy/fxbr.pfb. If you get Font shape `U/fxb03/m/n' undefined, libertine-legacy is not installed correctly.
    – user22108
    Dec 3, 2013 at 12:04
  • @user22108 Thank you, I do get exactly this undefined font shape, but on "input line 45", which is \maketitle, and the title uses no Greek letters. In any case, I followed the installation instructions (see comment on the answer below). What more need I do to install the package correctly?
    – Earthliŋ
    Dec 3, 2013 at 12:12

1 Answer 1

3

The documentation for libgreek says: the libertine-legacy (or earlier) package must be installed on your system for libgreek to work for math mode. That package is available from CTAN: /obsolete/fonts/libertine-legacy

7
  • I installed the libertine-legacy package from the link you provided and did sudo texhash followed by sudo updmap-sys --enable Map=libertine.map. The ls-R file contains the path to the package and the .map file enables successfully. Still, Greek letters don't show in math mode.
    – Earthliŋ
    Dec 3, 2013 at 12:02
  • Do kpsewhich libertine.sty and kpsewhich libertine.map to verify that the libertine-legacy ones are in use. Did you uninstall the more recent libertine package? Or install libertine-legacy in a personal texmf tree?
    – user22108
    Dec 3, 2013 at 13:49
  • Actually the libgreek documentation says that the newer libertine or libertine-type1 style file can be used in the document but the libertine-legacy map file must also be enabled (renamed to allow for simultaneous enabling of the new libertine.map).
    – user22108
    Dec 3, 2013 at 16:08
  • kpsewhich gives me /usr/share/texlive/texmf-dist/tex/latex/libertine/libertine.sty and /usr/share/texlive/texmf-dist/fonts/map/dvips/libertine/libertine.map, which are probably the wrong files. I tried to rename the libertine-legacy .map file and do sudo texhash, texhash doesn't seem to list the file, which is located in /usr/local/share/texmf/fonts/libertine-legacy/ and in /usr/share/texmf/fonts/. I don't have the same folder structure as suggested in the README file, so I'm not sure the files are in the correct place, though.
    – Earthliŋ
    Dec 3, 2013 at 16:40
  • The (renamed) map file should be accessible using kpsewhich. Map files have to be under fonts/map/dvips/... in a texmf tree.
    – user22108
    Dec 3, 2013 at 16:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .