3

I get the following error message when I try to compile the code below.

package calc Error :'\gdef' invalid at this point \title

What am I doing wrong?

\documentclass[a4paper,11pt]{book}

\usepackage[utf8]{inputenc}
\usepackage[frenchb]{babel}
\usepackage{lipsum}

% permet de faire une table des matieres par chapitre
\usepackage[french]{minitoc}
\setlength{\parskip}{10pt plus 1pt minus 1pt}

\setlength{\parindent}
% biblio ordonnee classique 
%\bibliographystyle{unsrt}
\title {Titre}
\author{Sssss}
\date{\today}
\begin{document}
% le titre

\maketitle

% preparation des minitocs
\dominitoc

% table des matieres generale
\tableofcontents
\include{intro}
\include{chap1}
\include{chap2}
\include{chap3}
\include{conclu}

\appendix

\include{annexe}

% bibliographie
\bibliography{allbiblio}

\end{document}
  • 1
    Welcome to TeX.SX! You're missing a mandatory argument to \setlength: it should be \setlength{\parindent}{0pt} if you really want a zero parindent. Please, don't (and don't use a nonzero parskip either). – egreg Dec 2 '13 at 15:42
  • 1
    \setlength requires two arguments (the length in question and the value to be assigned) but you're only supplying the first argument. In your code, \title is taken as the second argument to \setlength. Then, the world ends. – jub0bs Dec 2 '13 at 15:42
6

The correct syntax for \setlength requires a second argument; you probably want

\setlength{\parindent}{0pt}

Please, avoid setting \parskip to such a high value as 10pt. Your pages will be crossed by big white stripes that don't make reading easier in any way. However I can't recommend smaller values either. Paragraph indentation has served well typography and readers for five centuries; it's discreet an unobtrusive, while the nonzero parskip is saying “Look at me”.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.