6

I am using LyX 2.0.6 and Jabref 2.9. I am trying to incorporate my bibliography in Jabref into Lyx, however I get the following error message in JabRef:

Verify that LyX is running and that the the lyxpipe is valid [\.\pipe\lyxpipe].

The Lyx manual specifies that I should insert \\.\pipe\lyxserver.in, however, I read somewhere else that it should be changed to the same path as the one in Lyx (Also the manual referred to LyX 1.6, rather than 2). I also tried the \\.\pipe\lyxserver.in path but I got the same error message.

Before getting that error message, I had gone to Insert > List TOC > Bibliography in Lyx.

  • You don't have to use the 'Send to LyX' button in JabRef. After having done Insert -> List -> BibTeX bibliography, whenever you do Insert --> Citation in Lyx, you'll get a list with all entries in the .bib-file. – Torbjørn T. Dec 4 '13 at 8:47
  • 1
    But it is often easier to use the JabRef menu, than the lyx one. Its linked to the PDFs, and it displays more info without having to click. I often forget things like, is begio2009 the monograph and bengio2007 the paper or is it the other way round. Sure this could be solved with better bibtex keys. but using JabRef is nice. – Lyndon White Apr 24 '14 at 6:23
4

I've been having this problem for years, so I sat down to finally figure it out. Some people suggested it just didn't work on windows. It does.

Tested with Windows 7 Enterprise SP1. and Windows 10 tech preview, Lyx 2.1.3, and JabRef 2.10

On Windows, the LyX pipe is not a file. It is a special windows "Named Pipe".

A named pipe must have the name \\.\pipe\FOO where FOO can be anything, but the first part: \\.\pipe\ must always be there.

  1. Set on LyX under Tools, Preference, External Tools" LyX Pipe: \\.\pipe\FOO
  2. You must now close and reopen LyX
  3. Set on JabRef Options, Preferences, Settings for LyX/Kyle, LyX Pipe: \\.\pipe\FOO (no .in is required)
  4. Away you go. You do not have to restart JabRef, just Just select some rows and click send to LyX and they will appear at the Cursor

It has been suggested that you may need to run both LyX and JabRef as administrator to get them to work, I didn't find this but its not impossible. If you are having this issue, some futher investigation may be needed (eg the config file may not have suitable permissions set).

2

I work on Linux so I'm not sure it will work the same way on your system, but try:

  1. Search your computer for the file *lyxpipe*.
  2. In Lyx under Tools -> Preferences -> Paths paste the full path of the lyxpipe file, together with the name of the file (i.e. lyxpipe or lyxpipe.).
  3. In JabRef under Options -> Preferences -> External programs -> Settings for Lyx/Kile, paste again the full path of the lyxpipe file, together with the name of the file.
  4. Restart both programmes.

This should do the trick for you (I hope)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.