EDIT: On a suggestion I added:


and changed




This solved this specific problem, even though I now have an inputenc problem that is however probably not directly related to this exact issue.

I've encountered a problem I can't seem to understand, nor do I seem to find anything when googling the issue either. I dunno, maybe I'm just googling the wrong words..

I am using Os X with TexShop and have defined the BibTeX engine to run using biber.

I have (extracts):


\section{Some section}
Some text ... \cite{someBook}


First I ran LaTeX compile, and then ran BibTeX. (biber is confirmed running. Log confirms this along with a couple of warnings:

/var/folders/f6/9vk9f7jn0zx_7cngdjxv1rdr0000gn/T/10ttGvYx8U/citations.bib_9023.utf8, line 46, syntax error: found "of", expected "="
/var/folders/f6/9vk9f7jn0zx_7cngdjxv1rdr0000gn/T/10ttGvYx8U/citations.bib_9023.utf8, line 50, warning: 13 characters of junk seen at toplevel
"\x{fffd}" does not map to ascii at Biber/Output/BBL.pm line 430.
"\x{fffd}" does not map to ascii at Biber/Output/BBL.pm line 430.
INFO - This is biber 0.9.3
INFO - Logfile is 'report, main.blg'
INFO - Reading report, main.bcf
INFO - Found 7 citekeys in bib section 0
INFO - Processing bib section 0
INFO - Looking for bibtex format file 'citations.bib' for section 0
INFO - Found bibtex data file 'citations.bib'
WARN - Entry relevance-basedlanguagemod does not parse correctly: skipping
INFO - Sorting list 'MAIN' keys
INFO - No sort tailoring available for locale 'en_US.UTF-8'
INFO - Sorting list 'SHORTHANDS' keys
INFO - No sort tailoring available for locale 'en_US.UTF-8'
INFO - Writing 'report, main.bbl' with encoding 'ascii'
INFO - Output to report, main.bbl

Then when running LaTeX-compile again I get the following:

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (TeX Live 2011)
 \write18 enabled.
entering extended mode
(./report, main.tex
LaTeX2e <2009/09/24>
Babel <v3.8l> and hyphenation patterns for english, dumylang, nohyphenation, ge
rman-x-2009-06-19, ngerman-x-2009-06-19, afrikaans, ancientgreek, ibycus, arabi
c, armenian, basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danis
h, dutch, ukenglish, usenglishmax, esperanto, estonian, ethiopic, farsi, finnis
h, french, galician, german, ngerman, swissgerman, monogreek, greek, hungarian,
 icelandic, assamese, bengali, gujarati, hindi, kannada, malayalam, marathi, or
iya, panjabi, tamil, telugu, indonesian, interlingua, irish, italian, kurmanji,
 lao, latin, latvian, lithuanian, mongolian, mongolianlmc, bokmal, nynorsk, pol
ish, portuguese, romanian, russian, sanskrit, serbian, serbianc, slovak, sloven
ian, spanish, swedish, turkish, turkmen, ukrainian, uppersorbian, welsh, loaded
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
For additional information on amsmath, use the `?' option.
(./report, main.aux)
*geometry* driver: auto-detecting
*geometry* detected driver: pdftex
[Loading MPS to PDF converter (version 2006.09.02).]
) (./report, main.bbl)
(./report, main.toc) [1{/usr/local/texlive/2011/texmf-var/fonts/map/pdftex/updm
ap/pdftex.map}] [2] [3]
Overfull \hbox (14.92099pt too wide) in paragraph at lines 42--43
\OT1/cmr/m/n/12 page al-lows a wide range of data col-lec-tions, all of which a
re fetched from Wikipedia[    3],
[4] [5] [6] [7] [8]
./report, main.tex:119: Undefined control sequence.
<argument> Sch\x 


The line at ./report, main.tx:119 contains the \printbibliography command. I cannot seem to understand why I get this error.

My citations.bib file looks like this:

   author = {Hila Becker and Mor Naaman and Luis Gravano},
   title = {Learning Similarity Metrics for Event Identification in Social Media},
   institution = {Columbia and Rutgers University},
   year = {2010}

   title = {DBPedia},
   author = {Christopher Sahnwaldt},
   url = {http://www.DBpedia.org},
   year = {2013}

   title = {MIRFlickr},
   author = {Mark Huiskes and Bart Thomee and Michael Lew},
   url = {http://press.liacs.nl/mirflickr/},
   year = {2013}

   title = {Flickr},
   author = {The Flickr Team},
   url = {http://www.flickr.com},
   year = {2013}

   author = {The Wikimedia Foundation},
   title = {Wikipedia},
   url = {http://www.wikipedia.org},
   year = {2013}

   author = {Claudio Carpineto and Renato De Mori and Giovanni Romano and Brigitte Bigi},
   title = {An Information-Theoretic Approach to Automatic Query Expansion},
   institution = {Fondazione Ugo Bordini and University of Avignon},
   year = {2001}

   author = {Victor Lavrenko and W. Bruce Croft},
   title = {Relevance-Based Language Models},
   institution = {Center for Intelligent Information Retrieval, Dept. of Computer Science}, University of Massachusetts},
   year = {2001}

   author = {José R. Pérez-Agüera and Lourdes Araujo},
   title = {Comparing and Combining Methods for Automatic Query Expansion},
   institution = {Dpto. de Ingeniería del Software e Inteligencia Artificial, UCM and Dpto. Lenguajes y Sistemas Informáticos, UNED},
   year = {2008}

   author = {Christopher D. Manning and Prabhakar Raghavan and Hinrich Schütze},
   title = {Introduction to Information Retrieval},
   publisher = {Cambridge University},
   year = {2008}

   author = {Ricardo Baeza-Yates and Berthier Ribeiro-Neto},
   title = {Modern Information Retrieval: The concepts and technology behind search},
   edition = {2nd},
   publisher = {Pearson Education Limited},
   year = {2011}

If I press enter to ignore this error the report still compiles and produces a PDF that seems to be correct, but its still really annoying to get this error all the time.

  • 2
    Firstly you should use \addbibresource not \bibliography to specify your bib file. Secondly your bib file contains non ascii characters and these are need to be correctly recognised. If you files are stored as utf8 then you main file should include a \usepackage[utf8]{inputenc}. Commented Dec 4, 2013 at 11:45
  • @AndrewSwann This seemed to resolve the problem! Thanks! Now however I get a new error: ./report, main.tex:120: Package inputenc Error: Unicode char \u8:ÔøΩ not set up for use with LaTeX.
    – Geir K.H.
    Commented Dec 4, 2013 at 11:56
  • I do not see these characters in your posted code. The error says it occurs in line 120 of main.tex which you have not posted. Check that line for something strange. Also make sure both your tex file and your bib file have been saved in utf8. I the problem persists, you can add further information by editing your question. Commented Dec 4, 2013 at 12:24
  • I have updated my post now, @AndrewSwann. Line 120 is still the \printbibliography line. It's just a line lower down now due to me adding the \usepackage[utf8]{inputenc} line. I think the error message shows a grouping of chars rather then the specific problem char. (No idea why). I think it's the ü in "Hinrich Schütze". When viewing the generated PDF the name is written out as "Hinrich Schtze".
    – Geir K.H.
    Commented Dec 4, 2013 at 12:35
  • Yes, it must be that that is throwing the error. Try removing all auxillary files and recompiling from scratch. Commented Dec 4, 2013 at 12:54

1 Answer 1


Thanks to Andrew Swann for suggesting the following fix:

Added (important note: This was not necessarily directly related to my original problem, but was a part of the changes made before my setup worked without errors):


and changed:




This solved my problems.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .