3

I'm growing tired of the extra space below \section and \subsection in the memoir class - it's way too big.

How can I remove it - like one use \vspace{-20pt}$. This must be done for all \section and \subsection.

What I have right now:

\documentclass[12]{memoir}

%\usepackage[danish]{babel}       
\linespread{1.5}
\usepackage[bf, small, raggedright, compact]{titlesec}
\usepackage{lipsum}

\begin{document}
\chapter{Chapter title}

\section{Section heading} \lipsum[1]

\subsubsection{Subsection} \lipsum[1]

\end{document}
6
  • 1
    I've not used memoir but a cursory glance at texdoc memoir suggests \setafterSskip{ skip } is what you want with S being sec or subsec and skip being whatever length you want. Dec 4, 2013 at 13:48
  • 1
    Just remember to set it to say 1sp, since anything non-negative makes it an inline section title. 1sp is very very small, but not equal to zero.
    – daleif
    Dec 4, 2013 at 14:15
  • Okay, it appears that this is not what I need cause absolutely NOTHING happens... I think I need to make \linespread{1} after each \section and \subsection and back to 1.5 when the text starts. Should I do a redefine of the \section or can I fix it in another way? Dec 4, 2013 at 14:26
  • Your example minus titlesec plus \linespread{1.5} \setaftersecskip{1sp} seems fine by me in that there is no extra space below the \section it is the same as between lines of text. Remember that titlesec overwrites the memoir interface.
    – daleif
    Dec 4, 2013 at 14:46
  • Uh - turns out I wrote \subSUBsection and not \subsection nose poke. It looks good now - I think this is what i need. Dec 4, 2013 at 15:01

1 Answer 1

6

Use the built-in stuff from memoir. Thus drop titlesec and use

\OnehalfSpacing
\setaftersecskip{1sp}

Rather than setting \linespread you should use the memoir spacing macros.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .