I'm currently writing my master thesis with MiKTeX 2.8. Now I wanted to install dsfont. But since 2.8 seems not to be supported anymore, I tried to install the package manually. I downloaded the doublestroke package, which contains dsfont, here and followed these instructions:

  • I already created the folder C:\localtexmf a few months ago
  • I created a new folder dsfont in C:\localtexmf\tex\latex
  • I put the dsfont.sty file into that folder
  • In MiKTeX settings, I pressed the refresh FNDB and the Update formats buttons
  • I loaded the package via \usepackage{dsfont} in my main file

That did not work. I got no error messages, but 81 warnings. Since I did not know why it didn't work, I also followed these instructions:

  • I executed initexmf --edit-config-file=updmap.cfg
  • then I entered # <font name> or <package name> or what fits better for you Map dsfont.map into the file
  • I executed initexmf -u as well as initexmf --mkmaps
  • again, I pressed the refresh FNDB and the Update formats buttons

Still didn't work. Even worse, even if I don't try to load dsfont in my main file, the document is not compiled. That means that I can't keep working on my thesis even without using dsfont. The problem seems to be with BibTeX, because I get error messages from BibTeX:

I found no \citation commands

I found no \bibdata

Note that there is a folder for biblatex in the localtexmf folder: C:\localtexmf\tex\latex\biblatex. But I'm not sure that I really needed that one for bibtex to work. Furthermore, since I got these problems, there is also a new file called Masterarbeit.synctex(busy) in my main folder (Masterarbeit.tex is my main document).

So, does anybody know how to make it work again? This is pretty important, because I don't have much time left and I don't want to risk to mess everything up with a new installation of MiKTeX. What did I do wrong during my installation of dsfont? Please help me!

EDIT: uploaded the log file from Latex and also bibtex

UPDATE: Installed MikTeX 2.9 on a different PC, still the same errors/warnings. Something is wrong in the way I'm creating my Bib, but I don't know what since I did not change anything concerning my Bib.

  • Looks like everything is already messed up. It'll probably be quicker and easier to remove miktex 2.8 and do a clean install of miktex 2.9 and/or TeX Live 2013 (including dsfont). Perhaps somebody has a swift solution, but maybe you'd start the download in the meantime...
    – DG'
    Dec 5, 2013 at 20:07
  • The bibtex messages are warnings not errors. Without more informations egg log-files, it is not possible to say what wrong Dec 5, 2013 at 20:24
  • 1
    If you have internet, download MiKTeX version 2.9 and install it and update. This would be the easy way out. Did you run updmap?
    – azetina
    Dec 5, 2013 at 20:45
  • 1
    You need someone which can look at your system and sort it out. Dec 6, 2013 at 12:47
  • 4
    This question appears to be off-topic because according to comments it seems to be caused by a fundamental problem of OP's operating system.
    – Speravir
    Feb 6, 2014 at 23:39


Browse other questions tagged or ask your own question.