10

I want to use lower-case roman numerals in a list, and I used:

%Redefine the first level
\renewcommand{\theenumi}{\Roman{enumi})}
\renewcommand{\labelenumi}{\theenumi}

%Redefine the second level
\renewcommand{\theenumii}{\roman{enumii})}
\renewcommand{\labelenumii}{\theenumii}

But I get upper-case roman numerals for both the first and the second level (I actually get smaller roman numerals for the second level).

Is there a way to use lower-case roman numerals?

Here is an example of the code I used:

\documentclass[letterpaper]{article}

\usepackage[utf8x]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[spanish]{babel}
\usepackage{parskip}
\usepackage{amsmath}
\usepackage{amsthm}
\usepackage{mathtools}
\usepackage{amssymb}
\usepackage{fullpage}
\usepackage{graphicx}
\DeclareMathOperator{\lcm}{lcm}

\newtheorem{mydef}{Definición}
\newtheorem{theorem}{Teorema}
\newtheorem{lemma}{Lema}
\newtheorem{proposition}[theorem]{Proposición}
\newtheorem{corollary}[theorem]{Corolario}
\newtheorem{remark}{Nota}

%opening
\title{Tarea I}
\author{Pedro
    \and Mateo}
\date{11 de Diciembre de 2013}

\begin{document}

\maketitle

%Redefine the first level
\renewcommand{\theenumi}{\Roman{enumi})}
\renewcommand{\labelenumi}{\theenumi}

%Redefine the second level
\renewcommand{\theenumii}{\roman{enumii})}
\renewcommand{\labelenumii}{\theenumii}

\begin{enumerate}
    \item \
    \begin{enumerate}
        \item Muestre que $\mathbb{Q}(\sqrt[3]{2})$ no tiene automorfismos no triviales.
        \begin{proof}
            Dada la extensión de campos $\mathbb{Q} \subset \mathbb{Q}(\sqrt[3]{2}$
        \end{proof}

    \end{enumerate}
\end{enumerate}


\end{document}
  • 2
    your code works fine here (I get lowercase roman numerals for the second level). Could you post a minimal working example (MWE) that shows the context where your code fails? – Nico Boni Dec 5 '13 at 22:39
  • Ok, I've posted the entire code just to make sure is not the packages or something like that. – pjox Dec 5 '13 at 22:46
  • It seems to be a package issue. Comment out \usepackage[spanish]{babel} and you will see. – azetina Dec 5 '13 at 22:47
  • 1
    if you want to keep babel replace \usepackage[spanish]{babel} with \usepackage[spanish,es-lcroman]{babel}. the option es-lcroman will do the trick. – Nico Boni Dec 5 '13 at 22:51
  • @dcmst I invite you to post your comment as a possible answer. – azetina Dec 5 '13 at 22:54
11

According to the author of the Spanish version of babel lower case roman numerals should not be used when writing in Spanish.

You can find more information about this issue in this blog (in Spanish) and in the babel-spanish manual at page 4 (again, in Spanish).

Lower case roman numerals can be restored via the es-lcroman option, which is documented at the same page of the babel-spanish manual.

The result with \usepackage[spanish,es-lcroman]{babel} in the preamble is the following:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.