2

I'm using Ubuntu 12.04 with Xfce 4.8. Only in some applications, namely TexStudio (v2.6.6) and TexMaker (v4.1), Ctrl+I inserts one Tab character instead of making text italic.

How do I troubleshoot such a keyboard shortcut (mapping) issue?

4

Control I is Tab (I is character code 73 and control subtracts 64 leaving character code 9 which is TAB). Whether that code inserts a character into your document or does something in your editor depends on your editor. Personally I have never used an editor where Ctrl-i makes anything italic, but there may be one I suppose.

  • Never used Ctrl+i for italic? Open Office has this shortcut (at least in my version). Also, my TeXstudio has it. – Sigur Dec 6 '13 at 20:17
  • 1
    @Sigur I've used Open Office (and MS Office) as document viewers but never produced a document in either, and I use emacs for everything else, where ^I just runs whatever command is bound to TAB, usually some kind of indent command, depending on the mode. – David Carlisle Dec 6 '13 at 20:26
  • Sometimes I have to fill some reports and forms using doc files (unfortunately). This is the rule in my university. You're a luck man. lol – Sigur Dec 6 '13 at 20:30
  • Thank you David for the explanation. BTW, I also believe that being independent from the editor is a good practice.. – Orion Dec 6 '13 at 20:54
2

I'm using TeXstudio 2.6.2 (SVN 4111) Using Qt Version 4.7.4, compiled with Qt 4.7.4 D on Lubuntu 11.10.

As you can see on the image, the shortcut to Italic is in fact Ctrl+i. You can change it using the Options menu.

enter image description here

  • Thank you Sigur. All the shortcuts are untouched. For some reason, probably a bug in Xfce, I noted that some other keyboard shortcuts (like Ctrl+O) are not working too. I switched back to Gnome desktop and everything is fine now. – Orion Dec 6 '13 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.