35

My paper has the font TimesNewRomanPS-BoldMT not embedded in itself, and therefore fails the IEEE submission check.

I am able to embed it with Acrobat by printing the PDF. However, I find it changes the colors of my paper a bit.

So I wish for a direct way to produce a PDF that already embeds all the fonts with pdflatex.

As this answer suggests, the pdftexDownloadBase14 settings in the updmap.cfg file is indeed set to true. However, it is still not embedding it.

How may I fix this?

I am using Texmaker under Window, if that matters.

4
  • 1
    A working answer given by [egreg][1] [1]: tex.stackexchange.com/a/24005/42654
    – user42654
    Commented Dec 12, 2013 at 20:14
  • 1
    You may also use gs for that: stackoverflow.com/questions/2670809/…
    – math
    Commented Apr 4, 2014 at 12:59
  • I just tried to test fonts in XeLaTeX and they obviously get embedded automatically, because when I used an obscure font and then displayed the PDF on another computer that didn't have the font, the PDF was displayed correctly. This is how i set main font: \usepackage{fontspec} \setmainfont[Ligatures=TeX]{CMU Serif Roman}
    – edison23
    Commented Nov 13, 2015 at 11:29
  • Note that this issue is usually caused when you include a PDF (e.g. with \includegraphics) in your document, and that PDF has not embedded its fonts. Ismet5's answer will work for this, but you can also ensure that the included PDF has embedded fonts.
    – thomas8wp
    Commented Apr 22, 2020 at 12:57

4 Answers 4

20

I feel your pain I was in the same situation a minute ago for an IEEE conference. There doesn't seem to be a clear or easy answer anywhere on this. I wonder why they don't make this easier to do.

This worked for me and I hope it works for you:

  1. open your pdf file,
  2. select file -> print
  3. set your printer to be Adobe printer (assuming you already installed it)
  4. click on properties
  5. click the tab "Adobe PDF Settings"
  6. uncheck "Rely on system fonts only; do not use document fonts"
  7. click on the Edit... after Default Settings
  8. click on Fonts, add those missing fonts to "Always Embed" (It is recommended to save the properties as a new setting.)
  9. print the pdf file with the new settings, and your new pdf file should be good to go.

Tip: when (or if) it asks you to save the PDF settings file, save it in the suggested Adobe settings folder

Source: Click Here

4
  • 4
    Thanks a lot, but it may not be an answer candidate, as I am looking for a way of embedding all the fonts DURING COMPILATION. However, I do now solve the problem using this method, so +1. Commented Dec 22, 2013 at 15:18
  • Super clear instructions relevant for uploading a thesis to a repository when a non-embedded font was lurking in a figure somewhere - thank you. I was able to download a free trial version of Adobe Acrobat Pro to do this.
    – L Platts
    Commented Sep 8, 2014 at 17:39
  • It changes the coloring of PDF a bit from black to grayscale somehow. How to retain the same color? Commented Oct 31, 2018 at 5:56
  • 1
    Those who have mac but not Adobe Acrobat Pro. On Mac, there is an easier way to do this. Just open the pdf in Preview app, and do Export As PDF... For other OS, some ways are listed here kbpdfstudio.qoppa.com/how-to-embed-fonts-in-a-pdf-document
    – AvinashK
    Commented Dec 28, 2019 at 0:57
11

If you are using TeXStudio in Windows, Go to Options-> Configure TeXstudio->Commands->Ps2Pdf. In that field, just paste

ps2pdf.exe -dPDFSETTINGS#/prepress -dEmbedAllFonts#true -dMaxSubsetPct#100 -dCompatibilityLevel#1.3 %.ps

This will directly embed all fonts while compiling itself.

You can manually do this from windows command prompt. In windows command prompt, navigate to the location of the .ps file and paste

ps2pdf -dPDFSETTINGS#/prepress -dEmbedAllFonts#true -dMaxSubsetPct#100 -dCompatibilityLevel#1.3 file_name.ps file_name.pdf

I guess, for linux machine, you just have to use "=" in the place of "#"

2
  • THANK YOU! The compatibility portion fixed ps2pdf for me (which was throwing errors in every shell and inside TeXStudio)
    – VeraKozya
    Commented Mar 3, 2021 at 6:43
  • This answer only applies when ps > pdf conversion, correct? Commented Jun 29, 2021 at 1:11
10

Though I was not able to embed fonts while compiling, I found this solution.

Generate your pdf, turn it into a postscript file with pdf2ps, and then turn it back into a pdf while embedding the fonts. commands in linux: pdf2ps doc.pdf ps2pdf14 -dPDFSETTINGS=/prepress doc.ps doc2.pdf

3
  • works perfectly on windows!
    – ic_fl2
    Commented Jul 12, 2017 at 20:49
  • 1
    It works, but there is loss of quality. Is there any flag I can set to keep the quality the same?
    – toliveira
    Commented Jun 25, 2019 at 21:25
  • It works, but I lose all PDF metadata. And also all cross-references and hyperlinks.
    – piegames
    Commented Feb 15, 2021 at 16:48
1

There is a preflight function of Adobe Acrobat Pro you could leverage. IMHO, this is the easiest method. Here are the tutorial: https://www.youtube.com/watch?v=9SdIVy2D4b4

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .