My paper has the font TimesNewRomanPS-BoldMT not embedded in itself, and therefore fails the IEEE submission check.

I am able to embed it with Acrobat by printing the PDF. However, I find it changes the colors of my paper a bit.

So I wish for a direct way to produce a PDF that already embeds all the fonts with pdflatex.

As this answer suggests, the pdftexDownloadBase14 settings in the updmap.cfg file is indeed set to true. However, it is still not embedding it.

How may I fix this?

I am using Texmaker under Window, if that matters.

  • 1
    A working answer given by [egreg][1] [1]: tex.stackexchange.com/a/24005/42654 – user42654 Dec 12 '13 at 20:14
  • 1
    You may also use gs for that: stackoverflow.com/questions/2670809/… – math Apr 4 '14 at 12:59
  • Note that this issue is usually caused when you include a PDF (e.g. with \includegraphics) in your document, and that PDF has not embedded its fonts. Ismet5's answer will work for this, but you can also ensure that the included PDF has embedded fonts. – thomas88wp Apr 22 '20 at 12:57

I feel your pain I was in the same situation a minute ago for an IEEE conference. There doesn't seem to be a clear or easy answer anywhere on this. I wonder why they don't make this easier to do.

This worked for me and I hope it works for you:

  1. open your pdf file,
  2. select file -> print
  3. set your printer to be Adobe printer (assuming you already installed it)
  4. click on properties
  5. click the tab "Adobe PDF Settings"
  6. uncheck "Rely on system fonts only; do not use document fonts"
  7. click on the Edit... after Default Settings
  8. click on Fonts, add those missing fonts to "Always Embed" (It is recommended to save the properties as a new setting.)
  9. print the pdf file with the new settings, and your new pdf file should be good to go.

Tip: when (or if) it asks you to save the PDF settings file, save it in the suggested Adobe settings folder

Source: Click Here

  • 4
    Thanks a lot, but it may not be an answer candidate, as I am looking for a way of embedding all the fonts DURING COMPILATION. However, I do now solve the problem using this method, so +1. – Sibbs Gambling Dec 22 '13 at 15:18
  • Super clear instructions relevant for uploading a thesis to a repository when a non-embedded font was lurking in a figure somewhere - thank you. I was able to download a free trial version of Adobe Acrobat Pro to do this. – L Platts Sep 8 '14 at 17:39
  • It changes the coloring of PDF a bit from black to grayscale somehow. How to retain the same color? – Faizan Zaheer Oct 31 '18 at 5:56
  • 1
    Those who have mac but not Adobe Acrobat Pro. On Mac, there is an easier way to do this. Just open the pdf in Preview app, and do Export As PDF... For other OS, some ways are listed here kbpdfstudio.qoppa.com/how-to-embed-fonts-in-a-pdf-document – AvinashK Dec 28 '19 at 0:57

If you are using TeXStudio in Windows, Go to Options-> Configure TeXstudio->Commands->Ps2Pdf. In that field, just paste

ps2pdf.exe -dPDFSETTINGS#/prepress -dEmbedAllFonts#true -dMaxSubsetPct#100 -dCompatibilityLevel#1.3 %.ps

This will directly embed all fonts while compiling itself.

You can manually do this from windows command prompt. In windows command prompt, navigate to the location of the .ps file and paste

ps2pdf -dPDFSETTINGS#/prepress -dEmbedAllFonts#true -dMaxSubsetPct#100 -dCompatibilityLevel#1.3 file_name.ps file_name.pdf

I guess, for linux machine, you just have to use "=" in the place of "#"

  • THANK YOU! The compatibility portion fixed ps2pdf for me (which was throwing errors in every shell and inside TeXStudio) – VeraKozya Mar 3 at 6:43

Though I was not able to embed fonts while compiling, I found this solution.

Generate your pdf, turn it into a postscript file with pdf2ps, and then turn it back into a pdf while embedding the fonts. commands in linux: pdf2ps doc.pdf ps2pdf14 -dPDFSETTINGS=/prepress doc.ps doc2.pdf

  • works perfectly on windows! – ic_fl2 Jul 12 '17 at 20:49
  • 1
    It works, but there is loss of quality. Is there any flag I can set to keep the quality the same? – toliveira Jun 25 '19 at 21:25
  • It works, but I lose all PDF metadata. And also all cross-references and hyperlinks. – piegames Feb 15 at 16:48

I just tried to test fonts in XeLaTeX and they obviously get embedded automatically, because when I used an obscure font and then displayed the PDF on another computer that didn't have the font, the PDF was displayed correctly.

This is how i set main font:

\setmainfont[Ligatures=TeX]{CMU Serif Roman}
  • 2
    Font loading has nothing to do with font embedding. – Henri Menke Nov 13 '15 at 13:02
  • 1
    not sure what you mean - doesnt the fact, that the PDF was displayed correctly under the circumstances, imply the fonts were embedded? – edison23 Nov 13 '15 at 15:22
  • 1
    @HenriMenke as I wrote - "and then displayed the PDF on another computer that didn't have the font" and yes, I tested it as I wrote in the answer - I tried opening it on a computer which for sure couldnt load that file from system, because it wasn't there. That's why I assume it got loaded from the PDF. – edison23 Nov 14 '15 at 16:42
  • 1
    The default behaviour of pdftex is to embed the glyphs (I guess akin behaviour for xetex). That is to say, that only the glyphs that you actually use in a document are embedded, not the whole font. – Henri Menke Nov 18 '15 at 9:30
  • 1
    @HenriMenke thanks for clarification. Embedding glyphs seems to work perfectly, so maybe that's an answer as to why nobody cares to actually explain how to embed fonts (as noted in answers above) – edison23 Dec 3 '15 at 12:58

There is a preflight function of Adobe Acrobat Pro you could leverage. IMHO, this is the easiest method. Here are the tutorial: https://www.youtube.com/watch?v=9SdIVy2D4b4

Not the answer you're looking for? Browse other questions tagged or ask your own question.