8

I'm trying to change the default word spacing for some font. I know 2 ways to do it: setting \fontdimens or \spaceskip. With these approaches and microtype's \textls I get two different results, none of them satisfactory. How can I get the same (increased) interword space inside letterspaced text and between it and regular text?

Example:

\documentclass{book}

\def\test#1{{#1\relax
\textls[200]{test test} test test\par}}

\usepackage{microtype}

\begin{document}
\test{}
\test{\spaceskip 10pt}
\test{\spaceskip 0pt\fontdimen2\font 10pt}

\end{document}
  • 1
    Perhaps I'm not quite following, but what is your desired outcome? – bishopcranmer Dec 9 '13 at 15:12
  • 1. Increase default interword space; 2. increase letterspace locally; 3. get equal interword spaces – Vadim Radionov Dec 9 '13 at 15:13
  • 1
    Note the fontdimen setting is global – David Carlisle Dec 9 '13 at 15:21
  • Yes, I know it. In real work I set it for the whole document from the very beginning. But microtype seems to be using something else for its calculations. – Vadim Radionov Dec 9 '13 at 15:24
  • 1
    One possible reason to change default spacing: different languages have different mean character width (e.g. in Russian we don't have "i" or "l"). – Vadim Radionov Dec 9 '13 at 18:28
3

The question has multiple non specified assumptions. But in case you want to increase the default interword space, use XeTeX. See section 7.3 of fontspec's manual.

\documentclass[12pt]{article}
\usepackage{fontspec}
\setmainfont{Linux Libertine O}
\usepackage{kantlipsum}
\usepackage{microtype}
\begin{document}
\kant[1]
\addfontfeature{WordSpace=10}
\kant[1]
\textit{\kant[1]}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.