5

I'll start by saying I'm new to ubuntu and texlive.

I just installed texlive2013 and am trying to create a pdf on ubuntu 12.04 TLS.

I'm using both English and Hebrew, but neither seam to work: when trying to create the PDF I get the (apparently known) message:

Font LHE/cmr/m/n/10=jerus10 at 10.0pt not loadable: Metric (TFM) file not found

I've already installed texlive-fonts-recommended, but it doesn't seem to help.

I'm thinking that although the fonts are installed, there might be a problem getting their path.

Does anyone have any suggestions as to fixing this problem or understanding its cause?


TeX MWE:

%% LyX 2.0.2 created this file.  For more info, see http://www.lyx.org/.
%% Do not edit unless you really know what you are doing.
\documentclass[english,hebrew]{article}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{xunicode}
\begin{document}
\selectlanguage{english}%
hello\selectlanguage{hebrew}%
\end{document}
  • 2
    Well-written post with examples. As noted in your question here the problem is not with the .lyx or the .tex. It is with your TeX distribution and OS (I added the tag "ubuntu" for you). You might not want to go to the trouble, but if you reinstall a fresh Ubuntu, use install-tl-ubuntu --hebrew and upgrade to the newest stable version of LyX you will be able to compile the Hebrew docs you have posted. – scottkosty Dec 14 '13 at 20:46
  • So, did you try any of the suggestions below? Did it work? Did you do something else instead? – einpoklum Jan 29 '14 at 15:55
  • @einpoklum no, actually I wasn't able to do it, not even on ubuntu 12.04 (which I'm using now permanently). I just gave up after too many hours were wasted. – pazbunis Jan 29 '14 at 16:29
  • @user2190298: Would you mind commenting on the two answers, saying where things went wrong exactly? – einpoklum Jan 29 '14 at 16:37
2

The part of install-tl-ubuntu that is used for adding support for Hebrew is the following (I edited it so that it has a chance of working stand alone). I do not know if it will work for you or not without the rest of the script.

dTEXMFLOCAL="$(kpsewhich -var-value TEXMFLOCAL)"
WGET_CMD="wget --tries=5"
mkdir "/tmp/HebrewFonts" &&
cd "/tmp/HebrewFonts" &&
${WGET_CMD} "http://archive.debian.org/debian/pool/main/i/ivritex/ivritex_1.1.1-6_all.deb" &&
ar x "ivritex_1.1.1-6_all.deb" && tar -xf "data.tar.gz" &&
rsync -a "usr/share/texmf/" "${dTEXMFLOCAL}"
mktexlsr "${dTEXMFLOCAL}"
| improve this answer | |
  • Hi scott. Since my last post (still on Windows) I've installed Ubuntu and thought the two problems weren't related. As for the lines above - how do I run that? – pazbunis Dec 14 '13 at 22:18
  • @user2190298 To run the code (which I cannot say will work because it is taken from a larger script), put it in a text file, say installHebFonts.sh, and run sudo bash installHebFonts.sh – scottkosty Dec 14 '13 at 23:30
  • You would at least need to run sudo mktexlsr "${dTEXMFLOCAL}" to update TeX's database of files. If this installs new fonts, you would also need to run updmap-sys or updmap to enable the map file as well. (I have no idea how Ubuntu's TeX packages handle this stuff - only how TeX Live would do it. So use at your own risk.) – cfr Dec 15 '13 at 1:55
  • I've tried installing tl again using 'install-tl-ubuntu --hebrew' and I've installed Lyx again. Now I can create PDFs, but hebrew in math formulas produces "Latex Error: Command \hebgimel unavailable in encoding T1". I've tried changing the font but the "use non-Tex fonts (via XeTeX\LuaTex)" box is locked so I can't tick it. Does this make sense somehow? – pazbunis Dec 16 '13 at 12:14
  • The errors with pdftex are normal (in the sense that I have the same). Not being able to use XeTeX/LuaTeX is not normal. Try restarting your computer (in case the PATH wasn't loaded correctly), going to Tools > Reconfigure, and the exiting and opening LyX again. First start with a simple document (the default of File > New) and enter some text in English. When you go to File > Export do you see entries for PDF (LuaTeX) and PDF (XeTeX)? Can you export with them? If yes, then go and see if the "use non-Tex fonts (via XeTeX\LuaTex)" is clickable. – scottkosty Dec 16 '13 at 19:40
0

As your first option, try following @scottkosty's advice; but failing that, you can also try my similar workaround solution to this (also similar) problem:

How do I add Hebrew support to TeXLive on Windows (with pdfTeX+babel)?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.