When I do \input{file} in a .tex document I later import in LyX, LyX converts file.tex into file.lyx and changes \input{file} to \input{file.lyx}. But LyX doesn't do well with the TeX code it does not support natively and \input{file.lyx} is a rather corrupted conversion.

How can I make LyX just pass the code from file.tex to pdflatex as a part of a bigger file without LyX making any conversions?


1 Answer 1


"Hide" \input from LyX by adding to your preamble (Document > Settings... > LaTeX Preamble)


and then use


in your document.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .