1

I am trying to install Texmaker 4.1 on 32-bit Ubuntu 12.04 LTS. I downloaded the file from the official site and I am trying to install by using the following command:

sudo dpkg -i texmaker_ubuntu_12.04_4.1_i386.deb

However, this results in an error of whose origin I am unable to pinpoint. The error message is as follows:

$ sudo dpkg -i texmaker_ubuntu_12.04_4.1_i386.deb 
Selecting previously unselected package texmaker.
(Reading database ... 617874 files and directories currently installed.)
Unpacking texmaker (from texmaker_ubuntu_12.04_4.1_i386.deb) ...
dpkg: error processing texmaker_ubuntu_12.04_4.1_i386.deb (--install):
 trying to overwrite '/usr/share/texmaker/doc14hu.png', which is also in package texmaker-data 3.4-1~ubuntu12.04.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 texmaker_ubuntu_12.04_4.1_i386.deb

What can I do to remedy the situation? Any help and advice is greatly appreciated.

  • Why don't simply install it from the deb package as I suggested before? I think your ubuntu installation has a problem. – Aradnix Dec 16 '13 at 0:12
  • Yeah just like you mentioned I tried to install it by double clicking the .deb package when it failed, I considered trying the command line. By the way I am done with the TexStudio it works really well for now. – Vesnog Dec 16 '13 at 0:20
  • I used the following command and it took care of the problem. However, lot of overwriting operations were performed as far as I am concerned. – Vesnog Dec 16 '13 at 0:43
  • Mmm I think it is related with your own installation. – Aradnix Dec 16 '13 at 0:58
3

I've run into the same problem on Ubuntu 12.04.5 LTS 64-bit, Texmaker 4.3:

sudo dpkg --install texmaker_ubuntu_12.04_4.3_amd64.deb 
(Reading database ... 382851 files and directories currently installed.)
Unpacking texmaker (from texmaker_ubuntu_12.04_4.3_amd64.deb) ...
dpkg: error processing texmaker_ubuntu_12.04_4.3_amd64.deb (--install):
 trying to overwrite '/usr/share/texmaker/usermanual_fr.html', which is also in package texmaker-data 3.2-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 texmaker_ubuntu_12.04_4.3_amd64.deb

I forced the over write as follows... sudo dpkg --install --force-overwrite texmaker_ubuntu_12.04_4.3_amd64.deb

|improve this answer|||||
  • Your solution still works on ubuntu 15.10 with texmaker 4.5 – dragon2fly Nov 7 '16 at 1:23
0

I will suggest you to install TeXmaker using deb package with the following command.

sudo dpkg --install --force-overwrite texmaker_5.0.2_ubuntu_17_10_amd64.deb
|improve this answer|||||
  • The OP is running 32-bit Ubuntu 12.04 LTS. Will this work? – SabreWolfy Dec 5 '17 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.