6

I've got a particular problem with a custom chapter style. Essentially my chapter title is on the left page, then there is a picture on top of the right page (waves, see below) and below the picture, the chapter content (bla ble bli blo) starts.

+--------+--------+
|        |~~~~~~~~|
| Ch. 6  |~~~~~~~~|
|        |        |
|        |bla ble |
|        |bli blo |
+--------+--------+

I've got it working using a modification of \chapter{} for the left page, then

\newpage
\ThisULCornerWallPaper{1.0}{waves}
\phantom{placeholder}
\vspace{200pt}

and then the chapter content starts.

The problem is that floats don't know the top right area is taboo for them, so I might get:

+--------+--------+
|        |~[    ]~|
| Ch. 6  |~[Fig1]~|
|        |        |
|        |        |
|        |bla ble |
+--------+--------+

So {figure} first, then placeholder and \vspace, then content.

I've been looking into two solutions without success:

A) Preventing floats on this first page. I don't know how to do this without affecting all of the document (i.e. flafter) or setting the very first float manually to [b]. I haven't found a way to tell floats to just avoid a certain page or a certain area.

B) Setting the top margin for this page only. I've looked into geometry package, namely

\newgeometry{top=300pt}
\restoregeometry

But this doesn't work. First of all, \newgeometry uses \clearpage, but I don't want clearpages, I just want to change one page margin. I've deleted the clearpages and made my own \newcommands, but...

\newsamepagegeometry{top=300pt}
\restoresamepagegeometry

...doesn't work because it both sets and unsets the margins for the current page, instead of setting them for the current page and unsetting them for the next.

So I tried \afterpage{...} but there seems to be a known (or at least observed) issue that prevents

\newsamepagegeometry{top=300pt}
\afterpage{\restoresamepagegeometry}

from working, while manual placement of \restoresamepagegeometry among the next page text works fine. The above code apparently does not execute \restoresamepagegeometry at all, so the geometry remains at top=300pt for the rest of the document.

Any solution or an idea where to look would be most appreciated.

  • Hi! First, I'd like to say that this is an extra-ordinary first question, if only every question on the site showed such a quality! Second, notice that you can use backticks `...` to format the inline code pieces, as I did in my edit. Happy TeXing! – yo' Dec 16 '13 at 14:41
3

Your chapter heading can do the same as article.cls \maketitle which is

\global\@topnum\z@   % Prevents figures from going at top of page.

the setting is global but only affects the current page. Depending on the context, you might need to use \makeatletter ... \makeatother.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.