16

I'm a LyX user.

I have an article title with the following text:

β-glucosidase

I have this entry in BibTeX so I tried to type \beta-glucosidase or {\beta}-glucosidase but they don't work. I tried many research on internet and this website, I can't find out why the command \beta does not work. I do not want that it appears in italic like {$\beta$}

Any suggestion?

3
  • 1
    Add \usepackage{textgreek} to the preamble and use $\textbeta$? Edit: \beta works only in math mode. Commented Dec 19, 2013 at 14:16
  • 2
    @TorbjørnT. -- does \textbeta really need to be treated as math (enclosed in $ signs)? i think it will work that way, but that the $ signs aren't needed. Commented Dec 19, 2013 at 14:23
  • @barbarabeeton Oops, you're right. I changed my comment from upgreek/\upbeta to textgreek/\textbeta, and forgot to remove the $. Thanks. Commented Dec 19, 2013 at 14:24

1 Answer 1

15

\beta is a math-mode only macro, so it cannot be used in text mode. There are a couple packages which provides upright Greek letters.

  • upgreek defines \upalpha, \upbeta etc. which are meant to be used in math mode, i.e. $\upbeta$.

  • textgreek defines \textalpha, \textbeta etc. which are meant to be used in text mode.

In your .lyx file, go to Document --> Settings --> LaTeX preamble, add

\usepackage{textgreek}

and in the .bib file, write \textbeta. Alternatively, add \usepackage{upgreek} and write \upbeta.

The latter option has a heavier beta, so use whichever you prefer:

enter image description here

\documentclass{article}
\usepackage{upgreek,textgreek}
\begin{document}
$\beta$ -- \verb|\beta|

$\upbeta$ -- \verb|\upbeta|

\textbeta{} -- \verb|\textbeta|

\end{document}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .