5

This may sound like a crazy scenario, but whilst using fnpct (and the after-punct-space option especially) and the \autocite command from biblatex (using the option autocite=footnote), I realized the spacing around the footnote mark wasn't treated the same way as with the command \footnote. This is hardly noticeable in british, but very severe in french (from babel). A weird thing is that it is \footnote that doesn't seem to react to the after-punct-space option when french is the language, whereas \autocite does.

I'm using v2.8a of biblatex and fnpct v0.2k (2013/04/07).

Variants I tried:

  • neither \frenchbsetup{FrenchFootnotes=false} nor \usepackage[hang]{footmisc} help
  • not using anything from biblatex at all (footnote is still problematic)

I'd be satisfied if I could redefine the basic \footnote like it's autocite=footnote version, but I'm not savvy enough to know how to dig that information up.

Here's a code example, tuned for maximal graphical effect (the right alignment just helps visualize things, for example):

\documentclass[french,12pt]{article}

\usepackage{babel}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{fnpct}
\usepackage[babel]{csquotes}
\usepackage[autocite=footnote,autopunct=false]{biblatex}

\AdaptNoteOptNoMult\autocite

\renewcommand{\thempfootnote}{\arabic{mpfootnote}}

\begin{document}

\begin{minipage}{6cm}
\emph{Without \texttt{after-punct-space}:}
\begin{flushright}

Here I'm using footnote\footnote[2]{Check!}.

\setcounter{mpfootnote}{1}

And here\ldots\ autocite\autocite{nokeyneeded}.
\end{flushright}
\end{minipage}

\vspace*{1cm}

\setfnpct{after-punct-space=-1em}

\begin{minipage}{6cm}
\emph{With \texttt{after-punct-space}:}
\begin{flushright}
Here I'm using footnote\footnote[2]{Check!}.

\setcounter{mpfootnote}{1}

And here\ldots\ autocite\autocite{nokeyneeded}.
\end{flushright}
\end{minipage}

\end{document}

enter image description here

[edited to add the fnpct package version]

6

You've discovered two different and unrelated issues:

  1. The language definition file for French, frenchb.ldf, makes the following definitions at begin document:

    \let\@footnotemarkORI\@footnotemark
    \def\@footnotemarkFB{\leavevmode\unskip\unkern
                         \,\@footnotemarkORI}%
    

    This disables fnpct's own adaptions. Since fnpct has the means to set all those spaces around footnote marks in different situations the definition from frenchb-ldf isn't really needed and can be reverted again after begin document:

    \begin{document}
    \makeatletter
    \let\@footnotemark\@footnotemarkORI
    \makeatother
    
  2. The issue with \autocite is quite different. Here, fnpct's mechansim strikes back: \auocite eventually inserts \footnote which has also been redefined by fnpct. That use of \footnote does not find a trailing punctuation and assumes it comes after a word. This is why it inserts the before-footnote-space which is what you're seeing. The following example amplifies this:

    \documentclass[12pt]{article}
    
    \usepackage[T1]{fontenc}
    \usepackage[utf8]{inputenc}
    \usepackage{fnpct}
    \usepackage[autocite=footnote,autopunct=false]{biblatex}
    
    \renewcommand{\thempfootnote}{\arabic{mpfootnote}}
    
    \AdaptNoteOptNoMult\autocite
    
    \begin{document}
    
    \begin{minipage}{6cm}
    \begin{flushright}
      Here I'm using footnote\footnote[2]{Check!}.\par
      \setcounter{mpfootnote}{1}
      And here\ldots\ autocite\autocite{nokeyneeded}.\par
      \setcounter{mpfootnote}{1}
      \setfnpct{before-footnote-space=.5em}
      And here\ldots\ autocite\autocite{nokeyneeded}.\par
    \end{flushright}
    \end{minipage}
    
    \end{document}
    

    enter image description here

    There is no easy fix other than setting

    \setfnpct{before-footnote-space=0pt}
    

I will certainly fix issue 2 in fnpct (I already have fixed it in my development version). I'll probably also undo frenchb.ldf's redefinition of \@footnotemark when fnpct is loaded and instead adapt the before-footnote-space accordingly when French is the main document language.


Both issues are fixed in fnpct v0.4a 2013/12/23:

\documentclass[12pt]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[french]{babel}
\usepackage{fnpct}[2013/12/23]
\usepackage[autocite=footnote,autopunct=false]{biblatex}

\renewcommand{\thempfootnote}{\arabic{mpfootnote}}

\AdaptNoteOptNoMult\autocite

\begin{document}

\begin{minipage}{6cm}
\begin{flushright}
  Here I'm using footnote\footnote[2]{Check!}.\par
  \setcounter{mpfootnote}{1}
  And here\ldots\ autocite\autocite{nokeyneeded}.\par
  \setcounter{mpfootnote}{1}
  Text\footnote{foo} text
\end{flushright}
\end{minipage}

\end{document}

enter image description here

  • @ChristophB. you're welcome :) – clemens Dec 21 '13 at 14:24
  • 1
    @ChristophB. both issues are fixed in v0.4a – clemens Dec 27 '13 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.