I would like to create a new bold "Afirmação" ("Claim" in portuguese) environment through "Local Layout" in LyX (I don't want to create a new layout file). So I went to Document -> Settings -> Local Layout and copied the following code:

Style AfirmaçãoBold
CopyStyle             Theorem
LatexName             afirmacao
LabelString           "Afirmação \theafirmacao."

I got the environment formatted the way I wanted, but the enumeration is not right. I am using "Theorems (AMS, numbered by type)" and "Theorems (AMS-extended, numbered by type)" modules. This is what I got:


This is the first "AfirmaçãoBold" environment in the document, but I got it numbered 3. Maybe this has something to do with the fact that the numbered environment before it is a "Lemma 3". How can I make an independent numbering for it, so it can start from 1? Also, how can I get the option to use "AfirmaçãoBold*", that is, how can I have the option not to number it at all? (I would like to have both options to choose). Thanks very much!

1 Answer 1


You have


It means, that it should be numbered with thm. Removing [thm] should solve the problem.

  • Thanks. This solved the enumeration problem. Now, do you know how can I have the option to use the "AfirmaçãoBold*" environment?
    – LuizMMB
    Dec 20, 2013 at 16:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .