3

I have a problem compiling an article using natbib. I am using WinEdt to compile, for example this what I found online:

\begin{filecontents*}{bibtest.bib}
@book{goossens93,
        author = "Michel Goossens and Frank Mittlebach and Alexander Samarin",
        title = "The Latex Companion",
        year = "1993",
        publisher = "Addison-Wesley",
        address = "Reading, Massachusetts"
}
\end{filecontents*}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\documentclass{book}
\usepackage{natbib}

\begin{document}
\cite{goossens93}

\bibliographystyle{plain}
\bibliography{bibtest}

\end{document}

I do:

Shift+Ctrl+L (latex)

Shift+Ctrl+L (latex)

Shift+Ctrl+B (bibtex)

Shift+Ctrl+L (latex)

Shift+Ctrl+L (latex)

and finally

Shift+Ctrl+D (dvips), pspdf

And in the pdf I don't get the name of the cited authors but I get instead: (?)

Also I get an error when I do Shift+Ctrl+L:

"! LaTeX Error: File 'natbib.sty' not found"

I do not know how to fix that because natbib.sty is in the folder: *\MiKTeX 2.9\tex\latex\natbib

I will very much appreciate your help, thank you!

closed as off-topic by egreg, Mico, Werner, cslstr, Paul Gessler Jul 11 '14 at 18:23

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    Welcome to TeX.SX! Did you try refreshing MiKTeX's database? – karlkoeller Dec 21 '13 at 6:51
  • 4
    This question appears to be off-topic because it is about a non reproducible problem – egreg Jul 11 '14 at 17:48