1
\documentclass[12pt,a4paper]{article}
\usepackage{amsmath}\usepackage{amssymb}
\usepackage{tabularx}
\usepackage{graphicx} \usepackage{hyperref}
\usepackage{lscape}
\usepackage{rotating}
\newcommand{\specificthanks}[1]{\@fnsymbol{#1}}% Inserts a specific \thanks symbol
\usepackage[left=1.25in, right=1.0in, top=1.25in, bottom=1.0in]{geometry}
\usepackage{booktabs} % Allows the use of \toprule, \midrule and \bottomrule in tables for horizontal lines
\newcommand{\piRsquare}{\pi r^2}        
\title{{\Large Profitability of Moving Averages in the European Stock Market\thanks{My special thanks go to my supervisor Prof.Dr.Name for the excellent guidance and the provided dataset.}}}      
\author{ ABC \thanks{University World Email: \url{http://abc@xyz.com}}}}    
\date{December 20, 2013}                
%
\begin{document} \baselineskip=22pt
\begin{landscape}
\maketitle
%
\centerline{\bf ABSTRACT}
In this line abstract will need to be written.
%
\medskip

\medskip\medskip
%
\noindent \textbf{JEL Codes:} G11; G14;

\noindent \textbf{Keywords:} Technical Analysis; Moving Averages; Market Efficiency;

\medskip

\medskip\medskip

\noindent \textsc{Since the existence of} stock markets, is one of the controling... 
\end{document} 

In the LaTeX file I found a problem in a footnote but I couldn't solve it. When I open the file with the Kile editor, it compiles easily, but in Winedit, it is showing an error. What has actually happened?

  • I find two errors: an extra } at the end of the \url line, and a missing \end{landscape} before \end{document}. These are basic errors, and given your other questions I do urge you to take time to work on your general LaTeX understanding. The demo here has various not-so-good constructs, and I wonder if you are simply copy-pasting code without understanding it. – Joseph Wright Dec 22 '13 at 9:57
  • 3
    Both would produce errors, it doesn't matter which editor you use to compile. It could however be that Kile is set up to use nonstopmode by default, where TeX will try to ignore the errors and create a PDF regardless, but if you look at the log file the errors should be listed. About the errors, both of the error messages are actually quite clear ... – Torbjørn T. Dec 22 '13 at 9:58
  • Kile uses nonstopmode by default. Indeed, I can't figure out how to make it use anything else (though I would like to). By default, Kile will display errors and warnings at the bottom of the window automatically when you compile. More detailed information is available by clicking on the 'output' tab. The log can be viewed by clicking on the 'konsole' tab and viewing it in the usual way. – cfr Dec 22 '13 at 13:31
  • @cfr Settings --> Configure Kile --> Build. Find the engine(s) you use, and remove -interaction=nonstopmode from the options. – Torbjørn T. Dec 26 '13 at 9:03
  • @TorbjørnT.: Thanks. I've tried that and it just hangs if there's an error - I can't find a way of actually interacting with it (although it does then run in interactive mode). – cfr Dec 26 '13 at 14:03
3

As there are errors in your code, both of the editors will show these errors -- generally the editor used is completely irrelevant for what output you get, as they are just frontends to the same programs (pdftex, luatex, xetex, etc.) that actually generates the PDF.

The reason WinEdt halts at an error, while Kile apparently just ignores them, is that the former uses errorstopmode by default, while the latter uses nonstopmode. You can read more about these interaction modes in Where to find official (!) and extended documentation for tex/latex's commandline options (especially -interaction modes)? In Kile there is a panel called Log and messages where the errors are listed. You should always fix these.

For your specific example you get two errors, both of which are quite clear:

! Too many }'s.
l.26 ...y World Email: \url{http://abc@xyz.com}}}}

There's an extra } at the end of line 26, which is the line with the \url shown in the error message.

! LaTeX Error: \begin{landscape} on input line 30 ended by \end{document}.

Every \begin needs an \end, you've forgotten to close the landscape environment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.