1

Although the biblatex-dw package should be more appropriate for citing in footnotes, I prefer the verbose-* styles built-in Biblatex because those do not use a See note n° system, which I do not like. Besides, I am using LyX which citation button simply makes \cite and I don't think it is possible to change that. So I am using a trick to convert all citations to footnode citations (\let\cite=\footcite).

So here's my problem: when using \footcite (automaticly converted by the \let trick) in a footnote, parenthesis are added, which cripples my layout. Could someone point me out some tricky command or some place in the source of biblatex (if relevant) where I could disable this adding of parenthesis?

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc}
\usepackage[english,ngerman,frenchb]{babel}
\usepackage{csquotes}

\usepackage{filecontents}
\begin{filecontents}{file.bib}
@BOOK{fujimotouk,
  author = {Takahiro Fujimoto and Joe Tidd},
  title = {The UK and Japanese Auto Industry: Adoption and Adaptation of Fordism},
  year = {1993},
  series = {Imperial College working paper},
  langid = {english}
}
@UNPUBLISHED{entretiengerant,
  title = {Entretien avec le gérant de Destock Pièces Auto à Aulnay-sous-bois
    qui travaillait à l'époque chez Mercedes avenue de la grande armée},
  year = {2012},
}
\end{filecontents}

\usepackage[style=verbose-trad3,backend=bibtex8,autolang=hyphen,
language=auto]{biblatex}
\renewcommand*{\newunitpunct}{\addcomma\space}
\renewcommand*{\mkibid}{\emph}
\let\cite=\footcite
% first name first in bib
\DeclareNameAlias{sortname}{first-last}
\addbibresource{file.bib}
\begin{document}
\footnote{Some text \cite{fujimotouk}.}
\footnote{\cite{entretiengerant} Some text.}
\end{document}

gives,

result

Thanks

  • Hmm I just figured out it is because I use the \let\cite=\footcite trick to convert all \cite to \footcite. – elge Dec 22 '13 at 11:30
  • 2
    \fooctite (and by your redefinition \cite) checks if it is called in a footnote, and if that is case the citation is converted to a parenthetical citation instead to avoid double footnotes. Do you only use citations in footnotes? If you need some text before the cite, you might want to try \cite[some text]{entretiengerant} or \cite[some text][]{entretiengerant}. – moewe Dec 22 '13 at 15:20
  • Yes of course, I forgot this one, this should work, it could be inconvenient if I've got lots of text to write in the footnote before or after the citation, though. – elge Dec 22 '13 at 16:16
  • 1
    Just to add to that, when that solution isn't suitable (because, say, you have too much text in the footnote), you can use \textcite in the footnote. – cfr Dec 22 '13 at 18:05
4

The best solution would obviously be to use the appropriate \*cite commands for the task at hand. That is: Do not use \footcite{foo} within a \footnote{}, rather use \cite{foo} or \parencite{bar}.

By default biblatex turns nested footnotes (for example a \footcite within a \footnote) into parenthesised text (and issues a warning such as Package biblatex Warning: Nested notes on input line XX.) to avoid double (nested) footnotes.

The code responsible for this behaviour can be slightly modified to not add parentheses any more. Add the following to your preamble

\makeatletter
\renewrobustcmd{\blx@mkbibfootnote}[2]{%
  \iftoggle{blx@footnote}
    {\blx@warning{Nested notes}%
     \addspace{#2}}% this was: \addspace\mkbibparens{#2}}
    {\unspace
     \ifnum\blx@notetype=\tw@
       \expandafter\@firstoftwo
     \else
       \expandafter\@secondoftwo
     \fi
       {\csuse{blx@theendnote#1}{\protecting{\blxmkbibnote{end}{#2}}}}
       {\csuse{footnote#1}{\protecting{\blxmkbibnote{foot}{#2}}}}}}
\makeatother
  • Obviously, in this case one would want to set up LyX properly so as to allow to use \cite or \footcite whenever appropriate. – moewe Dec 22 '13 at 16:44
  • @elge But it has the side-effect of stripping all nested footnotes of their automatic parentheses, so the proper solution is to make sure LyX does the right thing. – moewe Dec 22 '13 at 16:52
2

I asked the LyX-users mailing-list if it is possible to tweak the insert citation button in view to get \footcite instead of \cite and what comes next actually permits to choose between the two. I had to update to version 2.1.0 beta2 and add this to document parameter local layout (my only modification was to put \footcite before \cite). Many thanks to Jürgen at LyX.

CiteEngine default
    footcite[]
    cite[]
    nocite
End

CiteFormat default
    # translatable bits
    _notcited not cited
    _addtobib Add to bibliography only.
    _footcite Foot:

    # macros
    !open [
    !sep ,
    !close ]

    !startlink {!<a href='#LyXCite-%clean:key%'>!}
    !endlink {!</a>!}

    !cite %!startlink%{%label%[[%label%]][[{%numericallabel%[[%numericallabel%]][[#%key%]]}]]}%!endlink%%!nextcite%

    !nextcite {%next%[[%!sep% %!cite%]]}
    !nexthashkey {%next%[[%!sep% #%key%%!nexthashkey%]]}
    !nextkey {%next%[[%!sep% %key%%!nextkey%]]}

    !textafter {%textafter%[[, %textafter%]]}

    # cite styles
    cite %!open%{%dialog%[[#ID]][[%!cite%]]}%!textafter%%!close%
    footcite %!open%{%dialog%[[%_footcite% #ID]][[%_footcite% %!cite%]]}%!textafter%%!close%
    nocite {%dialog%[[%_addtobib%]][[%key%%!nextkey% (%_notcited%)]]}
End

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.