0

I'm having some problems with the citations in the Tufte class. I have several questions related to this which i will post below, but first i will provide a minimum working example, test.tex:

\documentclass[nohyper,nobib,nofonts]{tufte-book}

\usepackage[utf8]{inputenc}  
\usepackage[american]{babel}  
\usepackage[backend=bibtex]{biblatex}  
\addbibresource{testBib.bib}  
\usepackage{hyphenat}  
\usepackage{csquotes}  

\begin{document}

\chapter{chapter}  
Some text~\autocite{bobylev}.  
\section{section}  
Lots and lots of more text~\autocite{Zhong}.  
\subsection{subsection}  
Delicious yummy text~\autocite{xu2004}. OmNomNom~\autocite{Lockerby}.

\printbibliography

\end{document}

And a simple bibliography testBib.bib:

@article{bobylev,
 author = {Bobylev, A. V.},
 title = {The Chapman–Enskog and Grad methods for solving the
 Boltzmann equations},
 journaltitle = {Soviet Physics - Doklady},
 number = {27},
 year = {1982}
}

@article{Zhong,
 author = {X. Zhong, R.W. Maccormack and  D.R. Chapman},
 title = {Stabilization of the Burnett equations and application to high-altitude     hypersonic flows},
 journaltitle = {AIAA Journal},
 year = {1993}
}

@article{Lockerby,
 title = "High-resolution Burnett simulations of micro Couette flow and heat transfer ",
 journaltitle = "Journal of Computational Physics ",
 year = "2003",
 author = "Lockerby, D.A. and Reese J.M."
}

@article{xu2004,
  title={Microchannel flow in the slip regime: gas-kinetic BGK--Burnett solutions},
  author={Xu, K. and Li, Z.},
  journaltitle={Journal of Fluid Mechanics},
  year={2004}
}

Which produces the following:

toc main body bibliography

In order to get numbered chapters, sections and subsection (not default in tufte-book class) i've done the following changes to tufte-common.def, changed

\setcounter{secnumdepth}{-1}

to

\setcounter{secnumdepth}{2}

and added

\setcounter{tocdepth}{2}

All of this compiles "fine", but produces the following errors and warnings

errors

Questions:

  1. The errors seems to have something to do with the changes i made in tufte-common.def, but how else to achieve numbered chapters, sections and subsections?
  2. Why doesn't the contents show sections and subsections, isn't that what \setcounter{tocdepth}{2} does?
  3. I have to manually delete the test.bbl and test-blx.bib files or add a new entry to the bibTest.bib file to update the bibliography, i.e. changes I've done in the .bib file won't show unless i do this. That can't be right can it?
  4. The bibliography is not ordered in the order they are cited and vice versa, I would prefer that the first citation in my text appear as [1], the second number as [2] etc. Not the way they do now, [1],[3],[2],[4]. I know that biblatex has options for sorting and different cite styles, but non of my efforts has yielded the results I'm looking for. Surely there must be a way to achieve references ordered in ascending order? I've also tried using baceknd=biber but that only produces more error messages.
  5. Does anyone have any experience with the warning? Interpretations and ideally a way to fix them.

Additional information: Using tufte-book class v3.5.0, MiKTeX 2.9 and Sublime Text 2.0.2 as text editor.

I realize this is a rather long post with many questions so I will be very grateful for answers to any or all of my questions :)

  • Solved #2, \setcounter{tocdepth}{2} needs to be set in the tufte-book.cls file instead of tufte-common.def – user2912781 Dec 30 '13 at 9:06
  • There is no need to change tufte-book.cls unless you want all of your documents using that class to look that way. You can change that in your own document, instead. – Joseph Dec 30 '13 at 14:07
0

Your example compiles fine, despite the erros, with the following (you may have forgotten \tableofcontents):

\documentclass[nobib]{tufte-book}
\usepackage[backend=bibtex,style=numeric,sorting=none]{biblatex}  
\addbibresource{testBib.bib}    


\setcounter{secnumdepth}{2}

\setcounter{tocdepth}{2}


\title{A simple document}
\author{An author}



\begin{document}


\maketitle

\tableofcontents


\chapter{chapter}  
Some text~\cite{bobylev}.  

\section{section}  
Lots and lots of more text~\cite{Zhong}.  
\subsection{subsection}  
Delicious yummy text~\cite{xu2004}. OmNomNom~\cite{Lockerby}.

\printbibliography

\end{document}

It seems that natbib, which Tufte classes use, is incompatible with biblatex, so that the error messages will not go away, although it compiles fine (see this).

As to your question #4, sorting=none does the trick.

  • o @Joseph: Could you possibly add an explanation of the relevance of natbib? Maybe I'm the only one puzzled by this but it is not obvious to me... [Why do I suddenly have to type a letter before I can use an @ symbol?] – cfr Dec 29 '13 at 21:54
  • Yes forgot \tableofcontents in my example :) thank you very much for your suggestions, will try them out tomorrow, to tired now. Will post update on how it went – user2912781 Dec 29 '13 at 21:55
  • @cfr, natbib is called by Tufte-LaTeX, see updated answer. – Joseph Dec 29 '13 at 23:15
  • @Joseph, Ah, thank-you. I looked in the .cls file but it seems it is squirrelled away in tufte-common.def. – cfr Dec 29 '13 at 23:23
  • Your solution for wuestion #4 worked like a charm, thank you very much. Natbibs incompatability with Biblatex probably explains #3 as well – user2912781 Dec 30 '13 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.