4

In an earlier question Arrow end type [-] unknown - even though library is loaded the consensus was that the bug "arrow end type unknown" is because of the wrong environment (smartdiagram), and that in tikzpicture everything should be fine. But I am trying to run with the tikzpicture and it still complaining about "arrow end type unknown". Help!

Here's the code:

\documentclass{article}

\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{tikz}
\usepackage{scalefnt}

\begin{document}
\pagestyle{empty}

\def\lineticktop#1#2{
  \draw[-] ({#1},3.075) node [anchor=south] {#2} -- (#1,2.925) ;
}

\def\linetickbot#1#2{
  \draw[-] ({#1},-0.075) node [anchor=north] {#2} -- (#1,0.075) ;
}

\def\microscope#1{
  \draw [thick,-         ] (#1 -0.25,2.15) -- (#1+0,3) -- (#1 +0.25,2.15) ;
  \draw [thick,fill=white] (#1 +0.00,1.50) circle (1) ;  
  \fill [white           ] (#1 -0.25,2.15) -- (#1+0,3) -- (#1 +0.25,2.15) ;
  \draw [thick,blue,->   ](#1-0.95,1.5) -- (#1+0.95,1.5) ;
}

\def\microtick#1#2#3#4#5#6{
  \draw [-,#5] (#1+0.375*#2,1.5+#3) node [anchor=#6,font=\small] {#4} -- (#1+0.375*#2,1.5-#3) ;
  \draw [red,thin] (#1+0.375*#2,1.3) to [out=-90,in=90] (#1+0.00,0.6);
}

\begin {tikzpicture} [scale=2]
  \draw[blue,thick,->]      (-1.1,3) -- (4.1,3) coordinate (x axis);

  \microscope    {1.41}
  \microtick     {1.41}{-0.2}{0.1}{$r$}{}{south}
  \microtick     {1.41}{ 0.7}{0.05}{\tiny $r+\epsilon$}{blue}{south}
  \microtick     {1.41}{ 2.1}{0.05}{\tiny $r+\gamma$}  {blue}{south}
  \microtick     {1.41}{-1.7}{0.05}{\tiny $r+\eta$}    {blue}{south}
  \draw[red,->] (1.41,0.6) -- (1.41,0.325) node [anchor=west] {$\scriptstyle \operatorname{st}$} -- (1.41,0.15) ;

  \lineticktop{-1}{$-1$}
  \linetickbot{-1}{$-1$}
  \lineticktop{ 0}{$ 0$}
  \linetickbot{ 0}{$ 0$}
  \lineticktop{+1}{$ 1$}
  \linetickbot{+1}{$ 1$}
  \lineticktop{+2}{$ 2$}
  \linetickbot{+2}{$ 2$}
  \lineticktop{+3}{$ 3$}
  \linetickbot{+3}{$ 3$}
  \lineticktop{+4}{$ 4$}
  \linetickbot{+4}{$ 4$}

  \lineticktop{+1.41}{}
  \linetickbot{+1.41}{$ r$}

  \draw[->]      (-1.1,0) -- (4.1,0) coordinate (x axis);
\end {tikzpicture}

\end{document}

The system is complaining about the argument {1.41} of \microscope (as well as 100 additional errors :-) ).

closed as off-topic by Torbjørn T., Andrew Swann, Peter Jansson, mafp, Jesse Jan 4 '14 at 16:05

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Your code compiles fine here, without error. What exactly is the error? – Torbjørn T. Jan 1 '14 at 19:10
  • It must be our outdated system. As I mentioned, I get the error message arrow end type '' '' unknown. – Mikhail Katz Jan 1 '14 at 19:11
  • Could be. If you add \listfiles just before \documentclass a list of all packages loaded and their versions will be printed, so you could check which version of TikZ/pgf you have. But did you get the arrow end type unknown error for \microscope? There is no special arrow type used there (or anywhere else, for that matter), so that sounds a bit strange. – Torbjørn T. Jan 1 '14 at 19:15
  • You might be right. Here is the exact message I get: ! Package pgf Error: Arrow end type `` '' unknown. See the pgf package documentation for explanation. Type H <return> for immediate help. ... l.2027 \microscope {1.41} It could be that the complaint about the microscope is unrelated to the complaint about the arrow. Will check the version now. – Mikhail Katz Jan 1 '14 at 19:20
  • 4
    This question appears to be off-topic because it is about an outdated version of TikZ/pgf. – Torbjørn T. Jan 4 '14 at 15:37

Browse other questions tagged or ask your own question.