5

I have TeXShop 3.26 running on a MacBook Pro with MacOS 10.9.1 and the TeXLive-2013 distribution.

Since a few days ago (after I updated to Mavericks) TeXShop does not automatically save my file when I typeset it (the red button on the upper left corner always has the dark spot).

I think this is very unusual, but I am not able to find out what the problem is.

Thanks!

  • Are you sure it doesn't save the file? Try looking at the file from the command line (Terminal) and see if it reflects your most recent changes. Because if the compiled document reflects your changes, it is hard to see how TeXShop could not be saving the file. (Unless TeXShop now saves it elsewhere temporarily and compiles only that version. But that would be both odd and rather complex.) In any case try to figure out if this is really an issue with autosaving on compilation or if it is just a problem with the indicator you are looking at. – cfr Jan 4 '14 at 1:24
  • Thank you for your help: You’re right, the time shown at the Terminal reflects the changes but, if I go back to TeXShop and quit the program after typesetting my file, I am asked to either save it (?) or leave it unchanged. If I choose the second, on the terminal the .tex file now shows the time when I first opened it (although all the other files remain unchanged). This is weird and it does not happen on my other computers. – javisor Jan 4 '14 at 10:45
  • That does seem weird. I suppose you've checked the application preferences? (Although it is hard to think why there would be a preference to set things up this way.) – cfr Jan 4 '14 at 16:54
5

I am the author of TeXShop. TeXShop always saves the source before typesetting, whether you use Auto Save or not. The "dirty file" indicator is unreliable in recent systems, and seems to have been completely removed in Sierra. The Apple setting "Ask to keep changes when closing documents" DOES NOT turn off Auto Saving, at least in Sierra. It merely puts up a dialog when you close a document asking if you want to revert to its startup state. If you do this, your source and output will not agree, since the output contains all the changes you made before the last typeset.

Some users have found a hidden Apple preference to turn off Auto Save for all applications. I spent several hours yesterday helping a user who turned it off, forgot about it, and then ran into trouble with recent systems. Eventually the user created a new account and ran TeXShop in the new account, where it ran perfectly.

Sierra fixes a number of Apple bugs which affected TeXShop, and I rather strongly recommend that users upgrade to it. I recommend leaving Auto Save on. In particular, TeXShop is NEVER tested with Auto Save off, since the Preference to turn it off is hidden from ordinary users.

  • Welcome to TeX.SE! Please take a moment to take our Tour! You may also want to look at what makes a good Minimal Working Example (MWE) – Tavrock Jan 31 '17 at 17:03
4

I am running TexShop 3.36 and Mavericks and ran into the same issue. I don't use the AutoSave feature in Mavericks (System Preferences > General > "Ask to keep changes when closing documents" is CHECKED). I fixed this problem by entering the following in Terminal:

defaults write TeXShop AutoSaveEnabled NO

and restarting TexShop. (I found this command in the change log here: http://pages.uoregon.edu/koch/texshop/changes_3.html) AutoSave is used by default in TexShop, and turning it off in Mavericks seems to produce this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.