When pdfLaTeXing the MWE below I get a Missing \endcsname inserted error message. The compilation proceeds with no errors as soon as the babel package is not loaded with the spanish option (well, to be true, I've only tried with the english option, and it works alright). Any hints on how to solve this issue, or on a possible workaround, would be welcome.

Follows the MWE:



\Shortstack[c]{A N E}

EDIT: I've just tried with the es-noquoting option and with the coupled commands \deactivatequoting-\activatequoting, as suggested in some posts about issues related to spanish babel, but to no avail. The problem remains the same.

  • 2
    An update to stackengine has been submitted to CTAN, based on Ulrike's answer. It should propagate in the coming days. Jan 6, 2014 at 13:27

1 Answer 1


stackengine uses the command \roman in a csname (which is simply not a good idea: \roman is for printing and not for the generation of command names) and this breaks as spanish redefines \@roman. As a workaround you can disable the redefinition but imho stackengine should be corrected.


\Shortstack[c]{A N E}
  • If \roman should not be used, does the same admonition apply to \romannumeral? Your answer is the first I've heard about this topic. Are there any other pointers to this topic? Jan 6, 2014 at 12:59
  • 1
    @{Ulrike Fischer, Steven B. Segletes}: That made it. I've resorted to using the es-lcroman option, though, which also solves the issue, as discussed on tex.stackexchange.com/questions/64687/…, and where further discussion can be found.
    – Marcos
    Jan 6, 2014 at 13:03
  • 3
    @StevenB.Segletes: \romannumeral is ok. And the same problem is with \arabic, e.g. here tex.stackexchange.com/a/32229/2388. But if you look a bit around you will find other similar discussion. Jan 6, 2014 at 13:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .