10

I'm having trouble using biblatex-apa to create a bibliography. When I run my project through latexmk, I get a reference section that looks like this:

Chan, K., Van Zwieten, L., Meszaros, I., Downie, A., & Joseph, S. (labelyearlabelmonth- labelday). Agronomic values of greenwaste biochar as a soil amendment. Soil Research, 45(8), 629–634.

Rondon, M. A., Lehmann, J., Ram ́ırez, J., & Hurtado, M. (labelyearlabelmonthlabelday). Biological nitrogen fixation by common beans (phaseolus vulgaris l.) increases with bio-char additions. Biology and Fertility of Soils, 43 (6), 699–708.

I took a look at this answer to a similar problem, but none of the suggestions worked for me.

My bibliography file entries look like this:

@article{rondon2007biological,
    Author = {Rondon, Marco A and Lehmann, Johannes and Ram{\'\i}rez, Juan and Hurtado, Maria},
    Date-Added = {2014-01-05 23:51:41 +0000},
    Date-Modified = {2014-01-05 23:51:41 +0000},
    Journal = {Biology and Fertility of Soils},
    Number = {6},
    Pages = {699--708},
    Publisher = {Springer},
    Title = {Biological nitrogen fixation by common beans (Phaseolus vulgaris L.) increases with bio-char additions},
    Volume = {43},
    Year = {2007},
    }

@article{chan2008agronomic,
    Author = {Chan, KY and Van Zwieten, L and Meszaros, I and Downie, A and Joseph, S},
    Journal = {Soil Research},
    Number = {8},
    Pages = {629--634},
    Publisher = {CSIRO},
    Title = {Agronomic values of greenwaste biochar as a soil amendment},
    Volume = {45},
    Year = {2008},
}

My .tex file looks like this (with most of the content removed for conciseness):

\documentclass[12pt,a4paper]{article}
\usepackage{fullpage,graphicx, url}
\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage[backend=biber,style=apa]{biblatex}
\usepackage[version=3]{mhchem}
\DeclareLanguageMapping{british}{british-apa}
\addbibresource{biochar.bib}
\date{}
\begin{document}
    \parencite{chan2008agronomic}.
    \parencite{rondon2007biological}
    \printbibliography 
\end{document}

Any help with this problem would be greatly appreciated. I'm pretty new to bib latex, so I'll admit that I could very well be doing something extremely stupid. I'm using TeXLive 2013 on Mac OS X Mavericks, if that makes any difference.

  • 2
    Either you use \DeclareLanguageMapping{british}{british-apa} or you use \usepackage[american]{babel}. Currenlty you mix the two. – Guido Jan 7 '14 at 5:15
  • Yup, that fixes it. I am not very smart. Thanks! – Eliza Weisman Jan 7 '14 at 15:40
  • 2
    @Guido Make that an answer, please. – lockstep Feb 15 '14 at 9:21
4

The file contains both

\usepackage[american]{babel}

and

\DeclareLanguageMapping{british}{british-apa}

One has to use one of the two options above, not both.

  • 1
    Shouldn't it be: One has to use (\usepackage[american]{babel} and \DeclareLanguageMapping{american}{american-apa}) or (\usepackage[british]{babel} and \DeclareLanguageMapping{british}{british-apa})? – moewe Feb 15 '14 at 14:51
  • Though note that with more recent versions of biblatex-apa \DeclareLanguageMapping is executed automatically for all supported languages (check the available .lbx files at ctan.org/tex-archive/macros/latex/contrib/biblatex-contrib/…). So the \DeclareLanguageMapping should not be needed. What one might need is a <lang>-apa.lbx in case biblatex-apa does not support <lang>. – moewe Feb 20 at 8:38
0

In my case, I use both \usepackage[indonesian]{babel} and \DeclareLanguageMapping{indonesian}{indonesian-apa}:

\documentclass{article}
\usepackage[indonesian]{babel}
\usepackage[utf8]{inputenc}
\usepackage[style=apa,backend=biber]{biblatex}
\DeclareLanguageMapping{indonesian}{indonesian-apa}

if I remove \DeclareLanguageMapping{indonesian}{indonesian-apa} then I get problem as you questioned.

I copied indonesian-apa.lbx from british-apa.lbx file (planning to modify things if necessary, but currently I don't know yet).

P.S.: I use Overleaf, which as of Feb 20, 2019 uses biblatex 2016/12/05 v3.7 programmable bibliographies (PK/JW/AB).

  • Welcome. Hmm, I think this is exactly what Guido and moewe stated in his answer. – JouleV Feb 20 at 8:35
  • 1
    In recent versions of biblatex-apa you won't need a \DeclareLanguageMapping at all, as it it executed automatically. In your case the important/problematic bit is that both biblatex and biblatex-apa don't have an indonesian localisation. biblatex won't have a lot of trouble with that (everything will just be in English), but biblatex-apa needs an .lbx file because it contains important macros, so you must get an indonesian-apa.lbx with the relevant definitions from somewhere (for example by copying an English file as you did). – moewe Feb 20 at 8:42
  • @JouleV moewe's comment is clearer, while Guido's is somewhat ambiguous. But yes, this is exactly what moeve's comment stated, but unfortunately his comment is not an answer.. – Hendy Irawan Feb 20 at 9:17
  • 1
    Overleaf has an outdated version of biblatex and biblatex-apa where the mapping is not yet automated, see also tex.stackexchange.com/q/474557/35864 – moewe Feb 20 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.