I'm trying to install new packages on my MiKTeX session with the following path: Package Manager(admin) from the menu of my computer --> In the box Name I write the name of the package, let say for example fancyhdr --> then I click on + --> but connect failed in tcp_connect. I always receive Failed in tcp_connect().

Please, could someone help me to solve this problem? I can't download any new package. It becomes impossible for me to write a document article.

  • What version is your MiKTeX?
    – Juri Robl
    Jan 7 '14 at 13:46
  • My MikTeX versior is 2.9 i'm very new on Miktex. i'm very in trouble with this software. Thank Jan 7 '14 at 13:57

Check if a) your MPM is allowed to connect to the internet (see your firewall/antivirus settings);


b) Are you connecting under a proxy? If so, you must setup the proxy through the menu Repository > Change Package Repository > select "Packages shall be installed from the internet" > Connection settings > (enter your proxy settings in the dialog box)

EDIT: the solution found in this question MikTeX 2.8 Update Error "Windows API error 87" solved the problem.

  • I have just tried to change settings according to what you notice me but unsuccesfully. This is the message i have got this: "Windows API error 87: Parametro non corretto". and this at the bottom: C:\ProgramData\MiKTeX\2.9\miktex/data/le\b1cfc6be702f63eea92ca0fbc9559e5c.fndb Thanks for your help Jan 7 '14 at 14:14
  • When you setup the settings and press "Next", it shows you the list of possible CTAN repository mirrors?
    – Cedric
    Jan 7 '14 at 15:02
  • Also: see if the solution described here helps: tex.stackexchange.com/questions/18144/…
    – Cedric
    Jan 7 '14 at 15:04
  • 1
    Now it is downloading MikteX packages. It works!. Thank you Cedric! your link is helpful. Jan 7 '14 at 15:18
  • 2
    I should say that it is not necessary to keep open the MikteX session while the user is downloading new package. User should switch off all the Miktex session and keep only Miktex Package Manager. Thanks again. Jan 7 '14 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.