2

According to APA rules, after each reference there must the digital object identification (doi). I use JabRef as a reference manager and for some reason, if I put an article doi on its "doi" field, it won't show up after the build on my editor, but if I put the doi on its "note" field it shows up. However, it's adding a period after the note field. I need a way to have the reference without an ending period.

Here's the LaTex document. I use TexPad as my editor.

\documentclass[12pt,a4paper,oneside]{report}
\usepackage[utf8]{inputenc}
\usepackage[portuguese, english]{babel}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage[sort, longnamesfirst]{natbib}
\usepackage[strings]{underscore}
\bibliographystyle{newapa} 
\usepackage{sectsty}
\chapterfont{\fontsize{14}{15}\selectfont}
\sectionfont{\fontsize{12}{15}\selectfont}
\subsectionfont{\fontsize{12}{15}\selectfont}
\renewcommand\bibsection{\section*{Referências}}
\bibpunct[:\ ]{(}{)}{;}{a}{,}{,}

\title{}
\date{}
\makeindex

\begin{document}

\cite{aldous-newviewsgrandparents-1995}

\bibliography{/Users/Ricardo/Documents/Ricardo/library2.bib}

\end{document}

It produces this:

Aldous, J. (1995). New views of grandparents in intergenera- tional context. Journal of Family Issues, 16(1), 104–122. doi: 10.1177/019251395016001006.

I need that last period out.

Thanks.

3
  • 1
    Why, it ends a sentence and thus should end with a period. But since you are using the note field, end the note with a macro that takes an argument. Then formatted with bibtex the entry will end up as blah blah\EatDot. since \EatDot takes an argument it swallow the added dot. – daleif Jan 7 '14 at 20:19
  • Thanks @daleif. I've tried what you suggested, but it didn't work. I added \EatDot as you said and added on my file \newcommand{EatDot}[1]{}, but it came out with the following errors on the new command: "Missing number, treated as zero", "Missing control sequence inserted" and "You already have nine parameters". There's also an error on the doi sequence with the \EatDot "Undefined control sequence". Any ideas? Thanks. – Ricardo Peixoto Jan 8 '14 at 10:26
  • Exactly where did you add that? Could you please update your question with exactly what you are doing, including a sample .bib file. – daleif Jan 8 '14 at 10:52
1

This works just fine. Again, I'd like to know why you want to remove the dot?

\begin{filecontents*}{sample2.bib}
@Article{test,
  author =   {An Author},
  title =    {A Title},
  journal =      {Some Journal},
  year =     {2013},
  note =     {Doi: 1234\EatDot},
}
\end{filecontents*}
\documentclass[a4paper]{article}
\newcommand\EatDot[1]{}
\begin{document}
\nocite{*}
\bibliographystyle{plain}
\bibliography{sample2}
\end{document}
3
  • 2
    I want to remove it because APA rules state that the doi must be entered without a final dot. – Ricardo Peixoto Jan 8 '14 at 11:29
  • Doesn't APA then provide a bibtex style that supports this? – daleif Jan 8 '14 at 11:34
  • I wish, if they do I still didn't find it. I don't know anyone else in my research área that uses LaTex. So, I tried again following your latest instructions, but removed the {#1} since it is to add a dot. If I write \newcommand\EatDot[1]{} on the same location, I get the dot removed. Thank you for everything @daleif. – Ricardo Peixoto Jan 8 '14 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.