4

The newpxmath package (version 2013/12/12 v1.061) makes angle brackets vanish from math mode:

\documentclass{standalone}
\usepackage{newpxmath}

\begin{document}
  $\langle x \rangle$
\end{document}

This results in just “x” rather than the expected “〈x〉”. Presumably the following messages from the .log file are relevant:

Missing character: There is no h in font zplsy!
Missing character: There is no i in font zplsy!

Can anyone suggest how to get those angle brackets back again, other than reverting to mathpazo?

  • It seems that newpx has already been fixed: the update should be available by tomorrow on TeX Live. I'll test it as soon as I'll install the update. – egreg Jan 8 '14 at 23:25
  • Yep! I reported the problem to Michael Sharpe as @egreg suggested. Within 45 minutes, Michael acknowledged the bug, fixed it, sent me corrected files, and said he'd send the fix to CTAN. Wow! – Ben Liblit Jan 9 '14 at 0:44
  • Good team work! – egreg Jan 9 '14 at 0:48
  • Absolutely. I tip my \hat to both of you! – Ben Liblit Jan 9 '14 at 0:51
4

It seems that the last update to newpx has introduced a bug: please, report it. For the time being, you can use the corresponding glyphs in newtx:

\documentclass{standalone}
\usepackage{newpxmath}

\DeclareFontFamily{U}{ntxmia}{\skewchar \font=127 }
\makeatletter
\DeclareFontShape{U}{ntxmia}{m}{it}{
  <-> \npxmath@scaled ntxmia
}{}

\DeclareFontShape{U}{ntxmia}{b}{it}{
  <-> \npxmath@scaled ntxbmia
}{}
\makeatother

\DeclareSymbolFont{lettersAbug}{U}{ntxmia}{m}{it}
\SetSymbolFont{lettersAbug}{bold}{U}{ntxmia}{b}{it}

\DeclareMathDelimiter{\langle}{\mathopen}{lettersAbug}{165}{largesymbols}{140}
\DeclareMathDelimiter{\rangle}{\mathclose}{lettersAbug}{166}{largesymbols}{141}


\begin{document}
  $\langle x \rangle$ $\bigl\langle x\bigr\rangle$
\end{document}

The second formula is to show that the bigger symbol is correctly set.

enter image description here


UPDATE

With yesterday's (2014-01-08) release of newpx (version 1.071), the problem has been solved, so the described patch is not necessary any more.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.