3

I just updated texlive and now LuaLateX no longer finds two ttf fonts situated in the same folder as the .tex file. Before I updated it all worked fine. Clumsy as I am I was having a latexmk session open in a terminal during the update and I am wondering if perhaps this could have broken some font cache, i.e. something similar to here? But on the other hand I am unsure as to whether it is using the font cache for fonts in the local folder? I tried mkluatexfontdb but that shouldn't really have any effect on files in local folder should it?

Can someone suggest what to try next?

btw I am now running version: beta-0.76.0-2013061817 (TeX Live 2013) (rev 4627)

  • 1
    Have you recently updated luaotfload via tlmgr? If so, do luaotfload-tool -u from the terminal. But first ensure your TeX Live is fully updated (there was a bug in an update to luaotfload that was solved a few days later). – egreg Jan 9 '14 at 17:27
  • Tested. Made no difference though :( – jonalv Jan 9 '14 at 17:34
6

As a hunch I tried removing the .ttf part in the specification and then it suddenly worked. Seems the BoldItalicFont and BoldFont in the \setmainfont command no longer is happy with getting the .ttf part of the file name. It probably makes sense but perhaps someone will find it useful knowledge some time... :)

2

NB this is an answer to the original question. I described my experience with adding a new ttf font.

I use lualatex, first installed tex-live, on my new Ubuntu 14 lts, I want to use from XP font constantia. I copied all CONSTANT*.TTF-files from XP in this map: /usr/share/fonts/truetype/msttcorefonts analogically(!) like other already available fonts. NB you have to be root for this!

Of course in the preamble something like:

\documentclass[pdftex]{book} %

\usepackage{pdfpages}

\usepackage[dutch]{babel}

\usepackage{luacode,luatexbase}

\usepackage{fontspec}% "[Renderer=Basic,Ligatures=TeX]"% nodig voor "--" and "---"

\setmainfont[Renderer=Basic,Ligatures=TeX]{Constantia} % case dependant

Then it's necessary to make this font available (in Abiword you can check it out) (you have probably to be root for some of these actions; "$" is terminal prompt)

$ fc-cache -fv 

$ mkluatexfontdb -vvv # per user and (idem):

$ luatools --configurations # luatex has to know where a new font is to be found.

All these steps were necessary. Greetz, Ernst van der Storm, The Netherlands

  • Please explain how your posting addresses the question that was posed. If it's not an answer, please consider re-posting it as a new question -- while making clear what the issues are that need to be addressed. – Mico Aug 6 '14 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.