I've used glossaries in the past running latest MikTex and Texniccenter on Windows 8.1 and now after 2 year I started to write a new paper using my old template and I got stuck using the glossaries.

My glossaries.tex-file looks like this:


% Display an arrow in front of the usage of an glossary entry

\newglossaryentry{CPU}{type=\acronymtype, name={CPU}, description={Central Processing Unit}, first={\glstext*{CPU}}}

    description={Enthalten i.d.R. Werkzeuge und Dokumentationen zur Software, um dem Programmierer den Einstieg zu erleichtern}}

% reset the acronyms used in the glossary-entries

    \glsentryitem{##1}\glstarget{##1}{##2} & ##3 & ##5\\[-1px]}%
     \glstarget{##2}{\strut}##4 & ##6\\}%
    \renewcommand*{\glsgroupskip}{ & &\\[-1.3ex]}%

       ##3\glspostdescription\space ##5}%
    \glstarget{##2}{\strut}##4\glspostdescription\space ##6.}%

And then just after the TOC I want to display the Acronyms on a cleared double page and the glossary entries on the following:


%%% Show all entries (even if not used):
\printglossary[type=\acronymtype,style=super3colleft] % acronyme

\printglossary[type=main] % glossary

I get an entry in the TOC but both pages are empty. What could cause those problems?

I'm compiling using texify (tried it using pdflatex as well but didnt work either) and with syncronisation with sumatra, my profiles look like the following:

enter image description hereenter image description here enter image description hereenter image description here

Is there maybe something missing as pre- or postprocessing which would collect all the entries and build the corresponding glossary-index-file!?

EDIT: I surely tried to fix it myself and I searched the internet. I found this quite interesting post: http://en.wikibooks.org/wiki/LaTeX/Glossary and there's something mentioned about the need to have Perl installed.

As I said, the last usage of my template is 2 years ago so I can't remember what I did exactly to make it work or which software I had installed on my computer back then. My directory does contain a glo, acn and ist-file after compilation which is, as far as I can see, necessary containing the glossary entries. The files look like:


% makeindex style file created by the glossaries package
% for document 'Hauptdatei' on 2014-1-10
actual '?'
encap '|'
level '!'
quote '"'
keyword "\\glossaryentry"
preamble "\\glossarysection[\\glossarytoctitle]{\\glossarytitle}\\glossarypreamble\n\\begin{theglossary}\\glossaryheader\n"
postamble "\%\n\\end{theglossary}\\glossarypostamble\n"
group_skip "\\glsgroupskip\n"
item_0 "\%\n"
item_1 "\%\n"
item_2 "\%\n"
item_01 "\%\n"
item_x1 "\\relax \\glsresetentrylist\n"
item_12 "\%\n"
item_x2 "\\relax \\glsresetentrylist\n"
delim_0 "\{\\glossaryentrynumbers\{\\relax "
delim_1 "\{\\glossaryentrynumbers\{\\relax "
delim_2 "\{\\glossaryentrynumbers\{\\relax "
delim_t "\}\}"
delim_n "\\delimN "
delim_r "\\delimR "
headings_flag 1
heading_prefix "\\glsgroupheading\{"
heading_suffix "\}\\relax \\glsresetentrylist "
symhead_positive "glssymbols"
numhead_positive "glsnumbers"
page_compositor "."
suffix_2p ""
suffix_3p ""


\glossaryentry{CPU?\glossaryentryfield{CPU}{\glsnamefont{CPU}}{Central Processing Unit}{\relax }|setentrycounter[]{page}\glsnumberformat}{vii}


\glossaryentry{SDK?\glossaryentryfield{SDK_gl}{\glsnamefont{SDK}}{Enthalten i.d.R. Werkzeuge und Dokumentationen zur Software, um dem Programmierer den Einstieg zu erleichtern}{\relax }|setentrycounter[]{page}\glsnumberformat}{vii}

I've even tried a MINIMAL working example of a german forum like this:

%Laden des Paketes

%Unser Testeintrag
description={Lecker gebackener Hefeteig mit verwurstetem Tier}}

%Unser Testeintrag Symbolverzeichnis
sort=rho,description={Dichte von irgendwas}}

%den Begriff im Text verwenden
\gls{wbrot}, \gls{Dichte}

%Ausgabe des Verzeicnisses
\printglossary[title=Unser Testglossar]
\printglossary[title=Unser Testsymbolverzeichnis,type=symbols]


I don't see the glossary in this minimal example, so it's probably nothing got to do with my full template but rather with the global settings of texniccenter to compile the glossaries somehow..

| improve this question | | | | |
  • 1
    If you don't have Perl installed, in order to compile the main glossary you have to run makeindex.exe -s glossary.ist -t glossary.glg -o glossary.gls glossary.glo while in order to compile the acronym list you have to run makeindex.exe -s glossary.ist -t glossary.alg -o glossary.acr glossary.acn – karlkoeller Jan 10 '14 at 11:32
  • In the above comment I supposed your .tex file is named glossary.tex. You also have to run pdflatex glossary before and after (probably twice) those commands. – karlkoeller Jan 10 '14 at 11:40

Yeah to answer the question myself, I now could finally found out what was causing me headache:

I saw the following output in TexnicCenter:

enter image description here

which put my attention on makeindex and as karlkoeller answered, I found out from here:

http://ewus.de/tipp-1029.html && http://ewus.de/tipp-1026.html

how to compile the files correctly. I changed my profile to the following, disabling the makeindex in the main window:

enter image description here

and adding two preprocessors (I'm not back to using the texify compiler which only runs as often as needed):

enter image description here enter image description here

Hopem that maybe helps somebody... :-)

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.