3

I use TeXnicCenter 2.02 Stable (32-bit) and MiKTeX 2.9.4533 (32-bit) on a 64-bit Windows 7.

I just installed both the 32-bit softwares (uninstalling the 64-bit ones) to check wether the problem was in the architecture or not. Seems not.

I've taken a model for my master thesis, which includes the packages hyperref and bookmark: When I try to build and view, LaTeX -> DVI, this simple code

\documentclass[10pt,a4paper,twoside,openright,oneside,openany,]{book}
\usepackage{hyperref}
\usepackage{bookmark}
\begin{document}
Hello world!
\end{document}

I get a MiKTeX Problem Report:

Some PostScript specials could not be rendered.

If someone could help me suggesting how to fix that problem, I would be very grateful.

  • 1
    You need to build using LaTeX > PDF, not LaTeX > DVI. – Werner Jan 11 '14 at 16:55
  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – jub0bs Jan 11 '14 at 17:15
  • @Werner I don't get an error compiling that with latex, though. Neither hyperref nor (from the documentation) bookmark require pdftex. So is this a limitation specifically of MiKTeX? – cfr Jan 12 '14 at 1:07
  • @cfr I’m quite sure, that the “problem report” does not appear on or after compiling, but when the OP wants to open the resulting DVI in the previewer of MiKTeX named YAP (I’ve seen this several times myself), because its default rendering method is “PK”. – Speravir Jan 14 '14 at 2:52
4

If I compile the document I get the following default driver:

Package hyperref Message: Driver (default): hdvips.

That means, after the DVI conversion the document needs to be converted to PostScript via dvips. The final step is usually ps2pdf to get PDF, because PostScript does not know bookmarks.

If the file is viewed with a DVI viewer, then all PostScript specials that contain information for the final PDF are useless for the DVI viewer.

There are several options:

  • Ignoring.
  • Changing the rendering method in MiKTeX to dvips.
  • Using hyperref driver option hypertex for previewing DVI. But it should be changed for PDF output.
  • To be more precise: Changing the rendering method of the previewer in MiKTeX named YAP. This is done in Menu “View” –> “Options…” –> Dialogue-tab “Display” –> “Default render method:”, and switch to “Dvips” (yes, it’s written with uppercase D). – Speravir Jan 14 '14 at 3:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.