5

The memoir's \mainmatter forces the next page to be a recto page. How can I disable that?

  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – jubobs Jan 12 '14 at 10:53
  • 1
    What do you have before \frontmatter? I use it as the first command after \begin{document}, so the first page is anyway a recto page. – quinmars Jan 12 '14 at 11:00
  • Sorry, I was supposed to write \mainmatter. Edited – Latex Jan 12 '14 at 12:19
6

You can simply patch the command \mainmatter to issue a \clearpage instead of \cleardoublepage.

Insert these lines in your preamble:

\usepackage{etoolbox}
\makeatletter
\patchcmd{\@smemmain}{\cleardoublepage}{\clearpage}{}{}
\patchcmd{\@smemmain}{\cleardoublepage}{\clearpage}{}{}
\makeatother

MWE:

\documentclass[openany]{memoir}
\usepackage{lipsum} %only for the example

\usepackage{etoolbox}
\makeatletter
\patchcmd{\@smemmain}{\cleardoublepage}{\clearpage}{}{}
\patchcmd{\@smemmain}{\cleardoublepage}{\clearpage}{}{}
\makeatother

\begin{document}

\frontmatter

\chapter{Intro}
\lipsum[1-10]

\mainmatter

\chapter{1st}
\lipsum[1-10]
\chapter{2nd}
\lipsum[1-10]

\end{document} 

As you can see the first page after \mainmatter is on a verso page and there is not any blank page:

enter image description here

I hope you are going to use the memoir's option openany otherwise the result is ugly...

  • Yes, I was already using it. Openany fixes blank pages between chapters, but not the one between frontmatter and mainmatter. Thanks! – Latex Jan 13 '14 at 14:21
  • Actually this answer has one problem, which I'd still like to see fixed. If you do double sided printing, and you use a wider margin on the side of the binding, you get the wider margin on the wrong side of the page starting from the mainmatter. You can actually see this problem in your own example. The page with chapter 1 should have the wider margin on the left side of the page. – Latex Jan 18 '14 at 22:04
  • @Latex Add \setlrmargins{*}{*}{0.666} \checkandfixthelayout right after \mainmatter. – karlkoeller Jan 19 '14 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.