3

I've been having the same problem as this person. My citations show up as [#], and not in the desired format (Author, Year).

I have checked natbib as advised: enter image description here

, and also in the citation menu itself: enter image description here

However, the PDF prints still only give me [#]. Any ideas?

Edit: My BibTex is an export file from Mendeley, and looks quite normal.

Thank you so much in advance.

  • What document class are you using? Would the problem persist if you switch to a different document class, say article? – Herr K. Jan 13 '14 at 17:36
  • I'm using Article (Komascript) – Christian Jan 14 '14 at 10:56
  • Which bibliography style are you using? Try plainnat. – Torbjørn T. Mar 7 '14 at 16:01
2

At least for the class "elsarticle" (Elsevier), the document class is loaded with a numbered citation style by default. For elsarticle, one adds the year by adding the "authoryear" option to the class by doing this in LyX: Document -> Settings -> Document Class -> Class options -> Custom: "authoryear"

Source: elsarticle documentation

0

In case you are using the Elsevier template elsarticle-template-1-num.tex in a raw editor without these options you have to add the option

\biboptions{authoryear}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.