0

Plot

Hey all!

I can't get rid of the 10:2 base at the x axis. I tried changing the precision, defining the ticks manually via xticks={...}. Everything works well on the y axis, I just can't figure out why this won't work on the x axis. Any help or input would be greatly appreciated!

Thanks!

\begin{tikzpicture}
\begin{axis}[%
width=\textwidth-\widthof{100},
height=8cm,
xmin=0,
xmax=0.04,
xlabel={[S]=$\frac{\text{mol}}{\text{L}}$},
xmajorgrids,
x tick label style={
/pgf/number format/.cd,
fixed,
precision=3,
    /tikz/.cd
},
ymin=0,
ymax=0.23,
ylabel={[V\textsubscript{0}]=$\frac{\text{mol}}{\text{L} \cdot \text{s}}$},
ymajorgrids,
y tick label style={
/pgf/number format/.cd,
fixed,
precision=2,
    /tikz/.cd
},
legend style={at={(0,1)},anchor=north west}
]
\addplot [
color=mycolor1,
mark size=2pt,
only marks,
mark=diamond*,
mark options={solid,fill=mycolor1}
]
table[row sep=crcr]{
0.001198562 0.0344717664736108 \\
0.002394254 0.0365895792303057 \\
0.003984064 0.0563386501133353 \\
0.011857708 0.111166458313178 \\
0.019607843 0.164120742512085 \\
0.031007752 0.220381981506325 \\
0.038461538 0.22523224268105 \\
};
%\addlegendentry{};
\end{axis}
\end{tikzpicture}
  • 1
    Try this: scaled x ticks = false, after xmajorgrids, – Umz Jan 14 '14 at 3:31
  • This did the trick! Weird I couldn't find out that myself. Thanks a lot! – idkfa Jan 14 '14 at 3:37

Browse other questions tagged or ask your own question.