3

I am attempting to enable PDF indexing of subsubsections in my Thesis but do not want them numbered. At the moment, the PDF output displays the subsubsections in the index but they link back to the last numbered subsection. If I increase the depth of numbering in (LyX: Document Settings > Numbering and TOC > Numbering) then the links work correctly but numbers are shown in the PDF document (which I don't want).

I have tried increasing the numbering depth and using \subsubsection* for the titles but then they are not shown at all in the index.

I also tried with \setcounter{secnumdepth}{2} but this also removes them from the index

I would prefer a document wide setting rather than having to change all the subsubsections but have even tried with \pdfbookmark which seems to cause some strange output in the PDF

I am using the hyperref settings from the classicthesis preamble (not from Document settings).
The files for a minimal example are linked below:

Files here

  • 2
    It doesn't work if you in Document --> Settings --> Numbering&ToC adjust the sliders so that subsubsections are included in the ToC but not numbered? – Torbjørn T. Jan 14 '14 at 8:03
2

Numbering is usually implemented in LaTeX by macro \numberline{<number>} inside the section title. With the help of option addtohook of package bookmark it can be automatically disabled for levels greater than two (subsubsection, paragraph, subparagraph, ...) independent from counter secnumdepth:

\documentclass{article}
\usepackage[colorlinks]{hyperref}
\usepackage{bookmark}
\bookmarksetup{
  open,
  numbered,
  addtohook={%
    \ifnum\bookmarkget{level}>2 %
      \renewcommand*{\numberline}[1]{}%
    \fi
  },
}

\begin{document}
  \tableofcontents
  \section{Section A}
  \subsection{Subsection B}
  \subsubsection{Subsubsection C}
\end{document}

Result

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.