5

I used the answer given here Replace (change) "Chapter 1" to "Chapter ONE" but it only should be in case without a following list of tables (lot) or figures (lof). When used as it is, the following lot and lof also replace the chapter number with a word as shown: enter image description here

enter image description here

What should be changed to prevent this?

  • 1
    Please also indicate how you would cross-references to chapters, figures, and tables to look like: Should they look like "Figure Two" or like "Figure 2"? Please also indicate which document class you use. – Mico Jan 14 '14 at 18:24
  • You tag this with titlesec; if you're exploiting this package, we need to know how. – egreg Jan 14 '14 at 18:56
  • @Mico In cross-referencing the numbering should remain in arabic, (Figure 2.1 / Figure 3). Am using the report class. – simo Jan 17 '14 at 14:16
  • @egreg Got the correction, am using the tocloft package not titlesec for toc, lof & lot. – simo Jan 17 '14 at 14:35
4

You don't mention in your question how you produced the string instead of the number. You mustn't redefine \thechapter, or all references pertaining to the first chapter will have the string ONE.

You can patch the \@makechapterhead instead, with the following:

\documentclass{report}

\usepackage{fmtcount} % for textual representation of numbers

% patch \@makechapterhead
\usepackage{etoolbox}
\makeatletter
\patchcmd{\@makechapterhead}
  {\thechapter}
  {\NUMBERstring{chapter}}
  {}{}
\makeatother

\begin{document}

\listoffigures

\chapter{First}

\begin{figure}
A
\caption{A figure}
\end{figure}

\end{document}

enter image description here

If you want to have “CHAPTER ONE” in front of your chapter title in the table of contents, you need to patch also \@chapter.

\documentclass{report}

\usepackage{tocloft}
\renewcommand{\cftchappresnum}{CHAPTER\ }
\setlength{\cftchapnumwidth}{10em}
\usepackage{fmtcount} % for textual representation of numbers

% patch \@makechapterhead and \@chapter
\usepackage{etoolbox}
\makeatletter
\patchcmd{\@makechapterhead}
  {\thechapter}
  {\NUMBERstring{chapter}}
  {}{}
\patchcmd{\@chapter}
  {\protect\numberline{\thechapter}}
  {\protect\numberline{\protect\NUMBERstringnum{\arabic{chapter}}}}
  {}{}
\makeatother

\begin{document}

\tableofcontents

\listoffigures

\chapter{First}

\begin{figure}
A
\caption{A figure}
\end{figure}

\end{document}

enter image description here

Note that you need \cleardoublepage before \listoffigures, if you want it in a new page. For showing the output I did not add it.

  • this code does not bring the expected output/effect. It affects the title in the body instead. I need to format the entry in the toc. It should read as Chapter One: .......1 not Chapter 1:.......1 – simo Jan 20 '14 at 13:11
  • @simo With the default setting, there is no “Chapter” in front of the chapter number in the TOC. Please specify better what you want in you question. – egreg Jan 20 '14 at 13:14
  • I've \renewcommand{\cftchappresnum}{CHAPTER\; } to take care of that. The issue is to have the chapter no. read as ONE not 1 – simo Jan 20 '14 at 13:53
  • @simo I added another patch for doing what you need. – egreg Jan 20 '14 at 14:27
  • @Bernard, @egreg; I've tested this option but it can't work with [titles]tocloft package which am using to format the entries in the toc lof and lot – simo Jan 27 '14 at 16:19
0

Here is an example using the titletoc and fmtcount packages:

\documentclass[11pt,a4paper]{book}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}

\usepackage{titletoc,  fmtcount}

\newlength{\len}
\titlecontents{chapter}[1.2em]{\bfseries \bigskip}%
{\contentslabel[Chapter \Numberstringnum{\thecontentslabel}.]{0.6em}\settowidth{\len} {Chapter \Numberstringnum{\thecontentslabel}}\hspace*{\len}}%]
{\hspace*{-1.5em}}%
{\hfill\contentspage}%
[\smallskip]%

\begin{document}

\tableofcontents

\chapter{Down the Rabbit-Hole}

\section{Alice was beginning to get tired}

\section{Drink me.  Eat me. }

\setcounter{chapter}{10}
\chapter{Who Stole the Tarts?}

\section{The Queen’s Croquet-Ground}

\section{The Mock-Turtle’s Story}

\end{document}

It shouldn't modify any cross-references using the chapter counter. It is multilingual for a small number of language thanks to the \FCloadlang command.

Here is the corresponding table of contents:

  • this code does not bring the expected output/effect. It affects the title in the body instead. I need to format the entry in the toc. It should read as Chapter One: .......1 not Chapter 1:.......1 – simo Jan 20 '14 at 13:12
  • I had not well understood the requirements. I modified the solution accordingly. – Bernard Jan 20 '14 at 22:43
  • @egreg; I've tested this option but it can't work with [titles]tocloft package which am using to format the entries in the toc lof and lot – simo Jan 27 '14 at 16:19
  • @simo: yes, as both titletoc's and tocloft's job is to format the table of contents, it's natural they can't be used together. I gave this solution to show it was easy to do with an alternative package. – Bernard Jan 28 '14 at 19:25
  • Does it mean that I can't achieve the results with the tocloft package? – simo Jan 29 '14 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.