10

I haven't been able to switch the quotation marks from Spanish to English in the document resulting from the MWE below. What, if anything, am I doing wrong or missing? And, yes, I've also tried by reversing the loading order of the polyglossia/babel and csquotes packages.

\documentclass{memoir}

\usepackage{xifthen, ifpdf, ifxetex}
\ifxetex
\usepackage{polyglossia}
  \setdefaultlanguage{spanish}
  \setotherlanguages{greek, english}
\else
\usepackage[greek, english, spanish, es-lcroman]{babel}
\fi

\usepackage{csquotes}

\begin{document}
\enquote{Quoted text} \par
\foreignquote{english}{English quotation marks}
\end{document} 
13

You need to pass the autostyle=true option to csquotes:

Sample output

\documentclass{memoir}

\usepackage{xifthen, ifpdf, ifxetex}
\ifxetex
\usepackage{polyglossia}
  \setdefaultlanguage{spanish}
  \setotherlanguages{greek, english}
\else
\usepackage[greek, english, spanish, es-lcroman]{babel}
\fi

\usepackage[autostyle=true]{csquotes}

\begin{document}
\enquote{Quoted text} \par
\foreignquote{english}{English quotation marks}
\end{document} 

By default autostyle is tryonce, so the quotation style is fixed after the first use. Older csquotes had an option babel, but this has been replaced by autostyle, which will work with both babel and polyglossia.

2
  • 3
    That made it. The documentation doesn't seem to me particularly clear on the interplay between the autostyle options and the foreignquotecommand. – Marcos Jan 16 '14 at 13:45
  • 1
    +1 I had the same problem and and agree with @Marcos. – Dr. Manuel Kuehner Aug 10 '20 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.