3

I am using SublimeText3, Biblatex (v2.8a), and Biber (v1.8). I have successfully compiled a bibliography and citations multiple times in the past. After switching to a modular design for my document, the bibliography stopped appearing even after removing the modules and reverting to a MWE (as shown below). I am getting citations like the popular, [Long1997 ], instead of 1.

I made no changes to my preamble, my build order, or package installations. I only added content. My debug process:

  1. Checked main.log(here) and main.bbl. "Missing 'biblatex' package" in bbl. Following error in .log:
Package biblatex Warning: Please (re)run Biber on the file:
(biblatex)                first
(biblatex)                and rerun LaTeX afterwards.
  1. Double-checked preamble that has successfully compiled in the past. Looks fine.
  2. Double-checked biblatex is still installed. It is.
  3. Double-checked bib entry that has worked before. Looks fine.
  4. Double-checked build order that has worked before. Looks fine.
  5. Asked friends to double-check. No objections.

What am I missing?

main.tex:

\documentclass{report}
\usepackage[style=numeric,backend=biber]{biblatex}
\addbibresource{nbabib.bib}
\newcommand{\HRule}{\rule{\linewidth}{0.5mm}}

\begin{document}
asdf \cite{Long1997}

\nocite{*}               
\printbibliography
\end{document}

nbabib.bib:

@BOOK {Long1997,
AUTHOR = {Long, Scott},
TITLE = {Regression Models for Categorical and Limited Dependent Variables},
PUBLISHER = {Potomac Books},
ADDRESS = {Dulles, Virginia},
YEAR = {2004}}

My build file, LaTeX.sublime-build:

    "cmd": ["latexmk", 
            "latexmk",
            "biber",
            "latexmk",
            "-cd",
            "-e", 
            "\\$pdflatex = '%E -interaction=nonstopmode -synctex=1 %S %O'",
            //"-silent",
            "-f", "-pdf"],

Update:

  1. Removed conflicting \usepackage{cite} due to incompatibility with \usepackage{biblatex}.
  2. Updated all packages via Tex Live Utility.
  • 1
    I'm surprised this document ever worked: the package cite is explicitly declared to be incompatible with the biblatex package (see '§ 1.5.4 Incompatible Packages' of the biblatex manual). ... And if I run your document from a terminal, I get ! Package biblatex Error: Incompatible package 'cite'. – jon Jan 18 '14 at 5:27
  • @jon Very strange. I am looking at a printed pdf where the citations are displayed correctly despite using the \cite command and biblatex package. I've compiled many times with successfully printed citations using the aforementioned configuration. Weird that it ever worked, let alone more than a dozen times. Thanks for the tip. – user2205916 Jan 18 '14 at 5:32
  • 2
    I should also point out that biblatex has a \cite command (among many others), but the package cite is fundamentally (and by design) incompatible with biblatex: you cannot have both \usepackage{cite} and \usepackage{biblatex} in your preamble, even though either one package will allow you to write \cite{<some bib key>} in your document. – jon Jan 18 '14 at 6:37
  • 1
    Can you make your .log and .blg files available somewhere? As @jon says, the file as it stands looks basically broken. Also, as you've not shown us the content of most of your document (loaded using \input) we are pretty limited on what we can say. – Joseph Wright Jan 18 '14 at 7:44
  • 1
    If you use a recent version of latexmk there is no need to run it three times and start biber manually, one call to latexmk is enough. – moewe Jan 18 '14 at 8:24
2

Found the problem. I added entries to .bib that were missing commas between fields. After replacing the missing commas, compilation worked and citations show as [1], [2], etc. rather than [label ]. I see many tex.SO topics/other articles on the web titled "missing bibliography" related to the use of Biblatex and biber. A general debug process for newbies if you use those two packages (Google the terms you don't recognize or refer to your TeX texts):

  1. Check the main.log and main.blg. Can Biber find your bib (i.e. "Found BibTeX data source 'pathhere/main.bib'")
  2. Check your preamble. Syntax errors? Packages compatible with each other?
  3. Check all entries in your bib file. If any entry in the .bib has incorrect syntax, compilation will fail. Even if the specifc entry you are trying to cite may be correct. Best practices may dictate otherwise, but you can have a comma after the last field of an entry, and blank fields (e.g. YEAR = {}) will not prevent compilation. Biber will delete such null entries. Modulation (separating your long main.tex into multiple .tex files) should not cause problems with the bibliography unless one of your modules has unusual syntax.
  4. Are the biblatex and biber packages installed? On a Mac, you can check by accessing "Tex Live Utility" and clicking "Packages." You can also try updating your installed packages by clicking "Updates."
  5. Build order. Your document must call the sequence pdflatex->biber->pdflatex->pdflatex on main.tex to build the document. In my case, the default ST3 LaTeXTools build used "latexmk," which calls pdflatex.
  6. Search here. Google keywords of your error. Ask a friend. Ask in IRC chatroom #latex.
  7. Ask here.

*Note to TeXperts: Feel free to edit. I'm still learning TeX-speak.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.