Running the minimal example

  author  = {Other, Anthony Norman},
  title   = {Some things I did},
  year    = {2014},
  journal = {J.~Irrep. Res.},
  volume  = {1},
  number  = {1},
  pages   = {1-10}

I get the warning There were undefined references.

I have read Question mark or bold citation key instead of citation number and know that I need to run:

  1. LaTeX
  2. Biber
  3. LaTeX

However, my editor is only set up to run BibTeX. How do I go about setting up my editor/IDE to be able to run Biber, and how do I run the LaTeX/Biber/LaTeX cycle?

Answers (sorted alphabetically by editor name)

Answer guidelines

  • Each answer should be for one editor. If the editor is cross-platform, if possible give a single answer with notes covering the minor platform variations.

  • Please edit the question to include new answers in the 'link list'

  • Each answer should be 'stand alone', i.e. don't say 'It's almost the same as editor Y but ...' for the editor part

  • Instructions for 'build tools' such as arara or latexmk are welcome but should explain how to set up the editor in question as not all editors allow simple addition of arbitrary tools

  • For background to this question, see meta.tex.stackexchange.com/questions/4192/…
    – Joseph Wright
    Commented Jan 18, 2014 at 18:31
  • 2
    Related tex.stackexchange.com/questions/5091/… Commented Jan 18, 2014 at 21:20
  • Would "my build script runs biber when necessary, out of the box" be a valid answer?
    – Raphael
    Commented Jan 18, 2014 at 23:54
  • @Raphael I've tried to tighten up the guidelines to cover this. Broadly, I'd expect each answer to be about an editor, with details for using build tools fine for inclusion but hopefully focussed on the editor side. Generic 'how to use build tool X' instructions can then be linked but not included directly here.
    – Joseph Wright
    Commented Jan 19, 2014 at 10:11
  • 8
    I'm adding a link to this from the biber documentation from version 1.9 and removing the meagre comments about this I currently have in there.
    – PLK
    Commented Jan 20, 2014 at 18:01

16 Answers 16



In the current release (2.12 branch), TeXstudio's build process ('Build & View') by default runs pdfLaTeX but not a bibliography tool, which you need to do separately. There is also a need to change the settings to run Biber rather than BibTeX for creating a bibliography.

The configuration step sets Biber as default bibliography tool.

In the TeXstudio preferences ('Preferences ...' on the Mac or 'Options -> Configure TeXstudio' on Windows), choose the Build tab and alter the 'Default Bibliography Tool' to 'Biber'. Save and close the preferences.

Default Bibliography Tool: Biber

The compile step is to ensure that the sequence

  1. LaTeX
  2. Biber
  3. LaTeX

is run. Manually this can be done as follows.

  1. Run 'Build & View' from the 'Tools' menu (or press the two green arrows icon), which will create a PDF but with the bibliography not completed

  2. Run 'Bibliography' from the 'Tools' menu.

    Tools > Bibliography

  3. Run 'Build & View' again: the bibliography will appear in the PDF.

It is possible to set up TeXstudio in alternative ways to achieve the same effect. The key is that you have to run the compile sequence LaTeX, Biber, LaTeX, which can be done 'by hand' (as I have) or can be automated in various ways. Note that the same general idea applies whatever editor is used: this is a feature of LaTeX and not of the editor.

Changing the bibliography tool only for a specific document

If you only want Biber for a single document, it is possible to specify this in the .tex file itself, using a so-called "magic comment". Simply add the following line at the top of your main .tex file:

% !TeX TXS-program:bibliography = txs:///biber

Or, if you want compatibility with the TeXShop and TeXWorks editors, use this instead:

% !BIB TS-program = biber

More details: TeXstudio user manual: 4.10 Advanced header usage, When and why should I use % !TEX TS-program and % !TEX encoding?

  • 1
    More or less what I put in tex.stackexchange.com/questions/153647/…
    – Joseph Wright
    Commented Jan 18, 2014 at 18:40
  • 1
    Also note that we need to install biber.
    – mja
    Commented Jul 2, 2018 at 15:17
  • Important note: in addition to the above, to run biber with TeXstudio on windows 10, you should run TeXstudio "as administrator" from windows. Otherwise, biber won't be executed from the editor no matter what options you changed.
    – hesham
    Commented Oct 26, 2018 at 21:37
  • 2
    @hesham In general it should not be necessary to run TeXstudio as administrator just to be be able to run Biber. It should be possible to execute Biber from within TeXstudio with only user permissions. I consider it quite dangerous to open an editor with admin permissions. If your Biber or TeXstudio requires admin permissions, then there is probably something wrong with your installation.
    – moewe
    Commented Mar 8, 2019 at 9:34
  • When I switch to Biblatex and Biber, TeXstudio does not give me any autocomplete for my citations anymore. Instead the editor just says "Citation missing", even though the PDF builds fine and the references are ok. With normal Bibtex, TeXstudio always autocompleted/suggested my citations. Is there anythign I can do about this? Commented Jul 12, 2021 at 8:56


Through Quick Build for ALL documents

Click on OptionsConfigure Texmaker:

enter image description here

The following window opens. In Commands tab replace bibtex % by

biber %

Make sure that you only have % after the path to Biber and not %.aux.

If for some reason, biber % does not work, you may want to try browsing to the biber.exe using the folder icon on the side (red arrow):

enter image description here

Though generally biber % should just work (and is preferable over biber.exe %).

This will make Biber the default for all documents.

Now choose the Quick Build tab in which further choose the second option as in the following figure:

enter image description here

Now your quick buid button should run pdflatexbiberpdflatexview pdf. In all steps above, don't forget to press OK in all windows before exiting.

Making only biber as user command

Go to UserUser CommandsEdit User Commands as in the following figure:

enter image description here

In the window that opens, type in the content as shown (ignore arara thing ;-)..):

enter image description here

Now your build list should have biber:

enter image description here

Now, you can choose to run (only) biber as standalone when you wish.

  • Texmaker-biber-biblatex usage Documentation in French for xm1math.net/doculatex/biblatex.html Commented Jan 19, 2014 at 4:34
  • 5
    Similar procedure on Linux just replace bibtex %.aux to biber % in Bib(la)tex command box without full path to binaries. I suppose this would work with MiKTeX and TeXLive distro if miktex bin and texlive bin path are added to system path. Commented Jan 19, 2014 at 4:45
  • 1
    related: tex.stackexchange.com/questions/44040/…
    – matth
    Commented Jan 21, 2014 at 8:01
  • if i choose to run (only) biber as standalone when you wish. What is the sequence of buttons I have to push? Is it command 2 + quick build or quick build + command 2? Thanks. @Harish Kumar
    – Ka Wa Yip
    Commented Jul 7, 2015 at 23:32
  • Are there any updates to this question using TeXmaker? I did this but still don't have bibliography in my document.
    – Pedro
    Commented May 28, 2020 at 14:30

Emacs with AUCTeX

(adapted from this answer)

AUCTeX Version 11.88

Version 11.88 has (currently) probably the best support for biber and biblatex among *TeX editors: AUCTeX is able to look at biblatex load options to automatically choose the right bibliography processor on a per-document basis, you need only to enable file parsing by setting TeX-parse-self to t. You can do that by adding the following code to your .emacs

(setq TeX-parse-self t)

or customizing that variable with M-x customize-variable RET TeX-parse-self RET. Most AUCTeX users enable parsing, probably you've already done that, check it before adding the above line to your .emacs. To see the value of the variable issue C-h v TeX-parse-self RET.

As in the previous version, C-c C-c (TeX-command-master) prompts for biber/bibtex when the .bbl file is newer than the .tex file (but now it prompts for the appropriate bibliography processor, and not always biber or bibtex). In addition, if you use the toolbar, in this version the bibliography button will automatically switch between Run BibTeX and Run Biber.

In this version, the variable LaTeX-biblatex-use-Biber is local (and no more customizable) for cases in which AUCTeX fails to automatically detect the correct processor.

AUCTeX Version 11.87

Version 11.87 is the first release of AUCTeX supporting biber by default and you don't need to add that processor to the command list. You can always run biber by hand with C-c C-c Biber RET.

Set biber as default bibliography processor

AUCTeX uses bibtex as default bibliography processor. In order to set biber as default bibliography processor (for all documents and not on a per-document basis) you have to activate parsing of LaTeX documents by setting the variable TeX-parse-self to t (see above). Then, in source files with an explicit


line, C-c C-c prompts for biber or bibtex processor when needed (ie, if the .bbl file is newer than the .tex file), depending on the value of the customizable option LaTeX-biblatex-use-Biber, which defaults to t. But until version 11.87, AUCTeX isn't able to automatically choose the bibliography processor, which is set in a LaTeX document with the backend load option of the biblatex package. Unfortunately, the bibliography button on the toolbar is always bound to Run BibTeX, even if LaTeX-biblatex-use-Biber is set to t.

Run latexmk

You can also run latexmk from AUCTeX. It isn't supported by default, but you can manually add it to TeX-command-list. Here are some Q&As on TeX Stack Exchange or Stack Overflow about how to setup latexmk in AUCTeX:

  • I know some people use Emacs without AUCTeX, but I still can't understand what the killer feature is that vanilla Emacs provides. (At least with respect to LaTeX.)
    – jon
    Commented Jan 18, 2014 at 20:46
  • @jon Well Emacs pops up in more than one answer in tex.stackexchange.com/questions/339/latex-editors-ides, so presumably some people use Emacs without AUCTeX. I guess the argument is that it's a good text editor in general, and without an add-in you get the same behaviour irrespective of the file you're editing. In any case, that doesn't affect the aim here :-)
    – Joseph Wright
    Commented Jan 18, 2014 at 20:51
  • @JosephWright -- Indeed. I pratically live inside Emacs and I'm not a computer person! I meant it more as a sort of (light-hearted) provocative, tongue-in-cheek, comment. Although I have often wondered what AUCTeX did badly or what plain Emacs did particularly well, or if it was simply a matter or what one is used to, rather like the divide between vi(m) and Emacs.
    – jon
    Commented Jan 18, 2014 at 21:14
  • 1
    I just added a 'vanilla' Emacs answer for anyone interested and/or stuck using vanilla Emacs. :-p
    – Adam Liter
    Commented Jun 2, 2017 at 23:04
  • 1
    @dpritch Well, it should be mentioned in the question post, rather in this answer. Anyway, I guess it should be safe to assume that one installs biber before trying to use it ;-)
    – giordano
    Commented Nov 12, 2017 at 12:40


Changing for all documents

If you want to make biber the default bibliography tool, you can simply change it in the TeXShop Engine preference panel.

Now the command is accessed in the same way that you would access bibtex: from the Typeset Menu choose Bibtex (Command-Shift-B).

preference pane

Changing on a per-document basis

Since most of us who are switching to biber still have documents which use bibtex it is often more useful to specify the bibliography engine directly in the document in the same way that other engines can be specified. See the following question for a full description of these possibilities.

To specify the bibliography program as biber or bibtex per document use either of the following lines at the beginning of your document. This will override what the default is set to on a per document basis. (To use bibtex on a document, replace biber with bibtex.)

% !BIB TS-program = biber
% !BIB program = biber

Alternatively, if you prefer an all-in-one command solution, you can use one of the various latexmk Engines that TeXShop provides. In this case you would instead one of the following lines to your document, according to the TeX engine you are using:

% !TeX TS-program = pdflatexmk
% !TeX TS-program = xelatexmk
% !TeX TS-program = lualatexmk

See the following question for how to do this:

  • Is it necessary to change paths with the advent of El Capitan here? I.e. something along the lines of /ust/texbin -> /Library/TeX/texbin?
    – moewe
    Commented Oct 7, 2015 at 12:18
  • 2
    If you use the (pdf)latexmk engine it will automatically choose between biber and bibtex. For more information about those engines see the Help->TeXShop Tips and Tricks document. Note: you may have to activate some of the engines (e.g., pdflatexmk is pre-activated but the latexmk engine may not be pre-activated). Commented Jun 9, 2016 at 13:20


The list of binaries known by TeXworks depends on where you get the program from: direct from the TeXworks site or as part of TeX Live or MiKTeX. However, at present Biber is not included in the standard set in any case. The steps needed to add Biber as an option are as follows:

  1. In the TeXworks preferences ('Preferences ...' on the Mac or 'Edit -> Preferences' on Windows/Linux, choose the 'Typesetting' tab. Go to "Edit > Preferences" and choose the "Typesetting" tab

  2. Use the '+' icon to add a new entry to to the 'Processing tool' list The "+" button is in the lower right corner of the "Processing tool" list

  3. Fill in the resulting box as follows:

    • Name: Biber
    • Program: biber
    • Arguments: $basename (use the 'plus' icon to add in a line for an argument)
    • 'View PDF after running': untick

    then OK this box and the preferences.

    The tool configuration window should have Biber as Name, biber as program, $basename in the Arguments window (where lines can be added with the "+" button), "View PDF after running" should be unchecked

    If 'biber' cannot be found if the Program entry reads only biber, you can browse for the full path filespec/biber.ext to the Biber executable. But this should usually not be necessary.

  4. To compile the document using Biber, first run pdfLaTeX (or XeLaTeX/LuaLaTeX) as normal, then choose 'Biber' from the dropdown and run it, before going back to pdfLaTeX and running it.

Build tools such as latexmk or arara can be set up in a similar way, probably leaving 'View PDF after running' ticked.



If you want to make Biber the default tool for compiling bibliographies, you have to go to "Options" -> "Execution Modes", "Console Application" panel, and change the value of the "Executable" field for the BibTeX accessory from bibtex.exe to biber.exe:

enter image description here

In this way, each time you launch the command BibTeX, WinEdt will execute Biber.

Even when you launch commands like PDFTeXify (and using MiKTeX's texify.exe as engine), WinEdt will be able to compile the bibliography with Biber.

LaTeXify add-on

For WinEdt versions 7 and above, there is a configuration component called "LaTeXify" available on http://www.winedt.org/config/menus/LaTeXify.html. It is provided with an install and an uninstall macro.

After installing it, you will have the chance to run either BibTeX or Biber, through toolbar buttons, menu items or keyboard shortcuts.

enter image description here

Apart from Biber, the add-on LaTeXify also adds commands for automated compilations, like PDFTeXify.

Here is a list

  • XeTeXify (runs BibTeX and PDFTeXify with XeLaTeX engine)
  • LuaTeXify (runs BibTeX and PDFTeXify with LuaLaTeX engine)
  • TeXify2PDF (runs BibTeX and TeXify+dvips+ps2pdf with LaTeX engine, v10 only)
  • LaTeXify (runs Biber and TeXify with LaTeX engine)
  • PDFLaTeXify (runs Biber and PDFTeXify with PDFLaTeX engine)
  • XeLaTeXify (runs Biber and PDFTeXify with XeLaTeX engine)
  • LuaLaTeXify (runs Biber and PDFTeXify with LuaLaTeX engine)
  • LaTeXify2PDF (runs Biber and TeXify+dvips+ps2pdf with LaTeX engine, v10 only)


Through LaTeX → PDF menu For ALL documents

Go to BuildDefine Output Profiles:

enter image description here

In the window that opens, choose any profile (say LaTeXPDF) and make the changes for bibtex field as in the following figure (again you can browse the biber.exe, see red arrow on the right).

enter image description here

Press OK and exit. Now in the main window choose LaTeXPDF from the build drop down tool button:

enter image description here

If you compile, biber is used now for all documents.

Making only biber as a standalone profile

Go to BuildDefine Output Profiles as explained before. Click on Add (1). In the window that opens type Biber (2), click OK to get Biber entry in the profile (3):

enter image description here

Now choose the profile Biber. In the window,

  1. Un-check Run (La)TeX in this profile.
  2. Un-check Do not use BibTeX in this profile.
  3. Check Do not use MakeIndex in this profile.
  4. Fill in the content for Path to BibTeX. You can also browse to biber.exe (see the red arrow to right).
  5. Fill in the Command line arguments to pass to as shown.

All 5 above in the following figure:

enter image description here

Now your build drop down tool bar has Biber. Choose and compile:

enter image description here

In all steps above, don't forget to press OK in all windows before exiting.

  • Hello @user11232! I used biblatex/Biber (with TeXnicCenter and portable MiKTeX, all up to date) for the very first time and discovered following: If I use a single .tex file without the TeXnicCenter project file .tcp, than the BibTeX button is gray out (it's german). First when I created a TeXnicCenter project, I could use the BibTeX button. Maybe it's only my machine. Maybe it's a normal case, I don't know. I used following TeXnicCenter profile (it's german).
    – Su-47
    Commented May 8, 2018 at 21:31

Kile (2.1.3)

This answer is adapted from the TeXStudio answer.

Kile's build process may or may not run a bibliography tool in addition to running LaTeX or PDFLaTeX. It will depend on precisely which Build option is run. In some cases, then, you may need to run the bibliography tool separately.

Using BibTeX

  1. To compile a document with BibTeX:

    • Choose 'Build -> Compile -> your preferred tool e.g. LaTeX or PDFLaTeX'
    • Choose 'Build -> Compile -> BibTeX'
    • Choose 'Build -> Compile -> your preferred tool'
    • Choose 'Build -> Compile -> your preferred tool'

It is possible to set up Kile in alternative ways to achieve the same effect. The key is that you have to ensure that there is a sequence


which can be done 'by hand' (as I have) or can be automated in various ways. Note that the same general idea applies whatever editor is used: this is a feature of LaTeX and not of the editor.

Using Biber

By default, Kile will never run Biber rather than BibTeX. Enabling Biber requires you to change the settings. The steps to do this are as follows:

  1. In Kile, open the preferences dialogue using 'Settings -> Configure Kile...'. Choose 'Tools -> Build' from the menu on the left.

  2. Under 'Select a Tool' there is a button 'New...'. Click this to create an option for Biber. When asked for a 'short descriptive name', type Biber and click 'Next'. From the dropdown menu, set the class of the new tool as 'BibTeX' and then click 'Finish'. This means the new tool will inherit BibTeX's settings as a basis.

  3. To configure the new tool, choose 'Biber' from the list under 'Select a tool'. On the right, you now have a detailed set of options. Leave the dropdown menu at the top on 'Default'. Then configure the options for the tabs underneath.

  4. 'General' tab:

    • 'Command': type biber (deleting anything already there)
    • 'Options': make sure this says '%S' (including the quotation marks)

    At this point, it should look like this:

    Kile with new tool, Biber, and the options in the 'General' tab configured

  5. 'Advanced' tab:

    • 'Type': select 'Run outside of Kile'
    • 'Class': select 'Compile'
    • 'Source extension': type bcf
    • 'Target extension': type bbl
    • 'Target file': leave blank
    • 'Relative directory': leave blank
    • 'State': select 'Editor'

    So the contents of the 'Advanced' tab should be:

    Configuring options in the 'Advanced' tab for Biber

  6. 'Menu' tab:

    • 'Add tool to Build menu': select 'Compile' (unless you have different ideas)
    • 'Icon': select/set as you wish
  7. Before applying your changes, check any build tools you use regularly from the list under 'Select a tool'. If any of these are set to run BibTeX, rather than Biber, change the commands appropriately.

  8. Click 'OK' at the bottom right of the dialogue.

  9. To compile a document with Biber rather than BibTeX:

    • Choose 'Build -> Compile -> your preferred tool e.g. LaTeX or PDFLaTeX'
    • Choose 'Build -> Compile -> Biber'
    • Choose 'Build -> Compile -> your preferred tool'
    • Choose 'Build -> Compile -> your preferred tool' (if a second run is required)

It is possible to set up Kile in alternative ways to achieve the same effect. The key is that you have to ensure that there is a sequence


which can be done 'by hand' (as I have) or can be automated in various ways. Note that the same general idea applies whatever editor is used: this is a feature of LaTeX and not of the editor.

  • 1
    Also of note: if a document includes the string \bibliography, Kile 2.1.3 is hard-coded to automatically run Bibtex after LaTeX or PDFLaTeX. To disable this, you have to click on LaTeX or PDFLaTeX or so on (whichever you are using) in the "Select a tool" list and uncheck the "Automatically run additional tools" checkbox; this will also disable automatic running of MakeIndex and Asymptote. However, future versions of Kile will detect the biblatex backend in use and run the appropriate tool, Biber or Bibtex.
    – David Z
    Commented Jan 19, 2014 at 5:53

VSCode using the LaTeX Workshop extension

First, ensure that you already have:


  1. Open the Settings JSON file as instructed below:

1.1. Click on the Manage gear icon, and then select Settings on the menu that appears.

Click on the Manage gear icon

1.2. Click on the curly braces pair on the top right of the window.

Select Settings

  1. Add or append (if already exists) the biber tool entry, and the compile recipe to the LaTeX Workshop entry in the opened JSON file:
  • The biber tool entry:
    "name": "biber",
    "command": "biber",
    "args": [
  • The compile recipe for biber using xelatex:
  "name": "xelatex -> biber -> xelatex*2",
  "tools": [

The whole LaTeX Workshop settings section should look like the following (your section could include other entries):

"latex-workshop.latex.recipes": [
          "name": "xelatex -> biber -> xelatex*2",
          "tools": [
  "latex-workshop.latex.tools": [{
          "name": "pdflatex",
          "command": "pdflatex",
          "args": [
          "name": "bibtex",
          "command": "bibtex",
          "args": [
          "name": "biber",
          "command": "biber",
          "args": [
          "name": "xelatex",
          "command": "xelatex",
          "args": [

Now you can click on the recipe title on the sidebar under LaTeX Workshop to build and view the file.

Using a recent VSCode LaTeX Workshop extension, an upgrade to intellisense in September 2021 (on GitHub here) made bibtex the default backend for VSCode so the following code needs to be added to your settings.json for the backend to be changed to biblatex:

"latex-workshop.intellisense.citation.backend": "biblatex",

Now the recipes from above will be able to run when using biber and not throw errors or undefined references similar to this question. Further information can be found on the LaTeX-Workshop intellisense FAQ hosted on GitHub here.

  • I have tried to do this, but substituting 'pdflatex' in place of 'xelatex' and it doesn't work. The error message says "pdflatex not defined". What should I do? Commented Mar 30, 2020 at 17:27
  • @PedroG.Mattos Do you have the pdflatex element defined as above (with name, command, and args keys) under latex-workshop.latex.tools? It's not just the recipes; the latex-workshop.latex.tools must contain all the tools declared under the recipes key.
    – ali14
    Commented Apr 8, 2020 at 9:10
  • I don't know what was going on, but now it is working without any changes in the .json file Commented Apr 8, 2020 at 9:37


Overleaf uses latexmk as the build tool behind the scenes, so bibtex or biber will be executed as needed, as well as re-running pdflatex. So there is no further action required on the part of the user.

  • 3
    Not completely related to the editor configuration. Still, it is probably useful to keep a small note here: latexmk is a great tool. There are a few rare edge cases where it can get hung up in an "error loop". In that case it may help to delete the Overleaf cache (overleaf.com/learn/how-to/Clearing_the_cache) and recompile from scratch.
    – moewe
    Commented May 9, 2022 at 19:16

Sublime Text 2 & 3 with LaTeXTools

For more on using Biber with LaTeXTools, see this wiki page. There are a few options depending on your OS and preferred configuration.

Using the default build engine ("traditional") with MacTeX (OSX) or TeXLive (Windows/OSX/Linux):

On these platforms, LaTeXtools' default (or "traditional") build engine uses latexmk by default. latexmk, in turn, supports biber+biblatex out of the box as of version 4.22 (at least in principle; there have been a few bug fixes since then regarding biber). Hence it doesn't make any difference for LaTeXTools whether you use bibtex or biber because it only cares about your .bib files (whose format does not depend on your choice of bibtex/biber) and supports both \bibliography and \addbibresource. Pressing Ctrl+b to build should be all you need to do.

Put differently, if you experience any issues, try $ latexmk <yourtexfile>.tex on the command line first.

Using the default build engine ("traditional") with MikTeX (Windows):

With MikTeX, LaTeXtools' default builder will use textify. Unfortunately, texify doesn't seem to support biber. However, it is possible to install and use latexmk on MiKTeX. After installing latexmk on MiKTeX, navigate to the user settings.

image showing navigating to Preferences > Package Settings > LaTeXTools > Settings - User

Then scroll down to the builder_settings block and add the line "command": "latexmk -cd -f -%E -interaction=nonstopmode -synctex=1" as shown.

image showing adding "command": "latexmk -cd -f -%E -interaction=nonstopmode -synctex=1" to builder settings

Using "basic" build:

LaTeXTools provides a "basic" builder, which takes care of running pdflatex, then bibtex or biber as necessary followed by pdflatex twice.

After installing LaTeXTools, navigate to the user settings.

image showing navigating to Preferences > Package Settings > LaTeXTools > Settings - User

Then scroll down to the builder setting and change its value to basic

image showing changing "builder" setting to "basic"

Using "script" build:

After installing LaTeXTools, navigate to the user settings.

enter image description here

Then alter the builder settings to script

enter image description here

and you can use a script. In the below example, for Windows, the build would run pdflatex then biber then pdflatex twice on the file.

enter image description here



Adding biber as a new menu in PDFLaTeX & biber

Go to BuildCompiler Options:

enter image description here

This opens:

enter image description here


  1. Choose PDFLaTeX & BibTeX
  2. Press Duplicate to get a copy of PDFLaTeX & BibTeX.
  3. Now press Rename and rename PDFLaTeX & BibTeX copy to PDFLaTeX & Biber as shown below:

enter image description here

Now you should have a profile named PDFLaTeX & Biber. Open it. Select BibTeX (arrow 2). Choose Binary Name (arrow 3) as in this figure:

enter image description here

Save and you will have PDFLaTeX & Biber build menu as:

enter image description here

Which will execute pdflatexbiberpdflatexpdflatex.

Biber as standalone

Go to BuildCompiler Options as explained above.


  1. Choose PDFLaTeX
  2. Press Duplicate to get a copy of PDFLaTeX.
  3. Now press Rename and rename PDFLaTeX copy to Biber as explained eariler.
  4. Make changes in Binary Name as shown below:

enter image description here

After saving, you will get a build menu named Biber:

enter image description here

This will run only biber.


Editor name: SublimeText / Sublime LaTeX package. https://tekonomist.wordpress.com

main.tex first line should say

%!TEX program = <program> 
%\ program: one of pdflatex (the default), xelatex or lualatex. This 
%\ selects the TeX engine.

bibliography.bib first 2 lines should say

%!TEX program = bibtex
%!TEX root = main.tex
  • instructions are from SublimeText/LaTeXTools on GitHub section: "Build engine settings" Commented Sep 10, 2015 at 9:21
  • 1
    Are you sure the first line of bibliography.bib should be bibtex instead of biber?
    – giordano
    Commented Sep 10, 2015 at 9:39
  • Is there a way to have Biber as the bibliography compiler on a global scale in Sublime or is it always necessary to specify the use of Biber on a per-document basis?
    – moewe
    Commented Sep 10, 2015 at 9:49
  • Speaking as a developer of LaTeXTools, I can assure you this doesn't work or if it does it is only by accident.
    – ig0774
    Commented Dec 7, 2016 at 16:43

(vanilla) Emacs (i.e., Emacs without AUCTeX)

tl;dr: (setq tex-bibtex-command "biber") and then (i) C-c C-f, (ii) C-c TAB, and (iii) C-c C-f

If, for whatever reason, you're stuck using Emacs without AUCTeX,1 you can configure the TeX print commands of TeX mode to use Biber instead of BibTeX.

There are several print commands to be aware of:

  • C-c C-b: Invoke TeX on the entire current buffer (tex-buffer)
  • C-c C-f: Invoke TeX on the current file (tex-file)
  • C-c TAB: Invoke BibTeX on the current file (tex-bibtex-file)

C-c C-b is useful if you want to test something out, but it creates temporary files with different names, so it is not really useful for sorting out bibliographies and crossreferencing, which depend on auxiliary files.

To get bibliography and crossreference stuff right, use C-c C-f. This command will first ask if want to save your buffer (if you have a modified buffer); then, it runs either tex-run-command or latex-run-command, depending on whether you are currently in plain-tex-mode or latex-mode (see the TeX mode page for a description of how the mode is chosen.)

By default, tex-run-command is set to tex and latex-run-command is set to latex. If you'd like to use the PDF versions, you can add the following to your Emacs configuration:

(setq tex-run-command "pdftex")
(setq latex-run-command "pdflatex")

Next, you can use C-c TAB to invoke either BibTeX or Biber. C-c TAB runs tex-bibtex-command, which is, by default, bibtex.

Like with the *tex-run-commands, you can change this to biber by adding the following configuration:

(setq tex-bibtex-command "biber")

After you've made these changes, you can then go through the LaTeX -> Biber -> LaTex compilation steps with C-c C-f -> C-c TAB -> C-c C-f.

  1. But really, you should probably use Emacs with AUCTeX, in which case see this answer.


latexmk is the default build tool

By default GNOME LaTeX (formerly LaTeXila) uses latexmk as a build tool. latexmk can automatically figure out if and when to run Biber, so there is no pressing need to actually set up that editor for Biber. The standard build settings will do just fine.

Biber only

In case you do want to set up a build job to only run Biber, follow these steps.

  1. Select Manage Build Tools in the Build menu

    Build>Manage Build Tools

  2. In the Manage Build Tools window select the little plus to the bottom of the right Personal Build Tools column

    Personal Build Tools menu

  3. Fill out the fields as follows

    • Label: Biber (this is the name shown in the menu later, of course you may pick anything else, but 'Biber' seems sensible)
    • Description: run Biber (again, the value of this field is not important for Biber to actually work)
    • Add a new job to the Jobs list by clicking the plus button on the bottom
    • Commands: biber $shortname, Post Processor: all-output

    Things should look roughly like

    Personal Build Tool window filled out as described above

Now you can select Biber from the second (custom) group of the Build menu whenever you want to run it manually.

Build menu with Biber available


Eclipse Texlipse program

Latex can be used in eclise http://texlipse.sourceforge.net/

Install the texlipse extension Click on external tool configuration external tool configuration enter image description here Click on program new configuration enter image description here Point to your program path enter image description here Do the same for biber enter image description here If you are using statet to get from Rnw => Tex => output you can configure the program using R code. You enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .