3

Is there a way to selectively de-activate desired links in hyperref?

For example, I would like to remove the footnotes from being linked and maybe also the citations. Imho it's fine if the TOC and the other lists (list of tables etc.) are linked, as well as the equations.

I have just read the documentation and other threads. But in my case I would like to do this globally and not just for one ref.

Edit:

Another possibility would be to make the undesired parts links, but not visible (e.g. black)

6
  • 3
    For footnotes: \usepackage[hyperfootnotes=false]{hyperref}. Jan 19, 2014 at 18:11
  • that works for the footnotes, thanks. But the citation remains.
    – TomM
    Jan 19, 2014 at 18:22
  • 1
    Would executing \hypersetup{colorlinks=true,citecolor=black} be an acceptable to you? The link would still be there, but nobody would notice it unless the mouse happens to hover over a citation...
    – Mico
    Jan 19, 2014 at 18:34
  • @Mico I tried this before, but then the links for the TOC are also gone, or at least they are not in a frame anymore.
    – TomM
    Jan 19, 2014 at 18:42
  • @TomM - Are you saying that you want the hyperlinks to be rectangular frames around the words rather than colored-in words?
    – Mico
    Jan 19, 2014 at 18:45

1 Answer 1

5

You mention that having the links "un-noticeable", i.e., black and thus not evident as links unless the mouse happens to hover over a citation, would be an acceptable solution. You could thus try

\usepackage{hyperref}
\hypersetup{colorlinks=true,
            citecolor=black}

AFAICT, there's no footnotecolor to modify, i.e., to set to black. However, you could study the answer by @MarcoDaniel to the posting Hyperref footnotes and section ref colors for a method for adding such an option. Alternatively, you could execute

\usepackage[hyperfootnotes=false]{hyperref}

to prevent footnote markers being made into hyperlinks.

2
  • 1
    Option hyperfootnotes is a package only option, the setting cannot be changed after package loading. Jan 19, 2014 at 19:47
  • @HeikoOberdiek - Thanks for catching this, I'll correct it.
    – Mico
    Jan 19, 2014 at 20:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .